Test failure "Disconnect Error: Application unexpectedly closed" in /testSearch/testRestoreDefaults.js

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cosmin-malutan, Unassigned)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(firefox24 affected)

Details

(URL)

(Reporter)

Updated

5 years ago
status-firefox24: --- → affected
Severity: normal → critical
(Reporter)

Comment 1

5 years ago
Here is the Jenkins log :

TEST-PASS | /tmp/tmpScTjkE.mozmill-tests/tests/functional/testSearch/testRestoreDefaults.js | testRestoreDefaults.js::setupModule
TEST-START | /tmp/tmpScTjkE.mozmill-tests/tests/functional/testSearch/testRestoreDefaults.js | testRestoreDefaultEngines
TEST-PASS | /tmp/tmpScTjkE.mozmill-tests/tests/functional/testSearch/testRestoreDefaults.js | testRestoreDefaults.js::testRestoreDefaultEngines
TEST-START | /tmp/tmpScTjkE.mozmill-tests/tests/functional/testSearch/testRestoreDefaults.js | teardownModule
Timeout: bridge.execFunction("806ee7ca-1a1e-11e3-92b0-005056bb28e6", bridge.registry["{07b0c862-153d-4683-8c44-e983865cee39}"]["runTestFile"], ["/tmp/tmpScTjkE.mozmill-tests/tests/functional/testSearch/testRestoreDefaults.js"])

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed
Timeout: bridge.set("a55699ac-1a1e-11e3-92b0-005056bb28e6", Components.utils.import('resource://mozmill/modules/mozmill.js'))

INFO Passed: 15
INFO Failed: 1
INFO Skipped: 0
Severity: critical → normal
(Reporter)

Updated

5 years ago
Severity: normal → critical
Happened today on 25.0b2: 
> http://mozmill-release.blargon7.com/#/functional/report/837c1e0f361ac93453ee6972193b5ead

If this cannot be fixed in the next 24 hours please disable this test on Beta.
How often did that happen, Anthony? If it is a one time failure I don't want to disable the test. Just get it retriggered. Mostly all disconnects seem to be caused by a slow machine (high cpu load).
It was just the one time.

Comment 5

5 years ago
I see a total of 4 failures here:
http://mozmill-release.blargon7.com/#/functional/failure?from=2013-09-01&test=%2FtestSearch%2FtestRestoreDefaults.js&func=teardownModule

All from September (10th, 12th, 24th and 27th), all with the [ku] locale, all on the release testruns. No failures on the daily runs.

Marking as WFM. If we see this again (especially if with [ku]) we should reopen and investigate more.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.