Closed Bug 915372 Opened 6 years ago Closed 6 years ago

Inspector can only be opened once per app per connection

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(firefox26 verified, firefox27 verified)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified

People

(Reporter: jryans, Assigned: jryans)

References

Details

Attachments

(1 file, 1 obsolete file)

STR:

1. Connect the App Manager to a device
2. From My Device -> Installed Apps, start some app, like say Gallery
3. Click Debug on Gallery to open the toolbox
4. Switch to the Inspector tab
5. Close the toolbox
6. Click Debug again on the same app (Gallery)
7. You will see the Inspector tab is selected, but the actual content of the tool does not appear.  Other tools appear to work fine.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
The changes I made in bug 912646 to keep the client connected when a remote target closes exposed a few cleanups that were missing in the inspector code path.

Previously, these weren't required since the client would go away when a toolbox is closed, but that's no longer true when you are remote.
Attachment #804798 - Flags: review?(dcamp)
Component: Developer Tools: App Manager → Developer Tools: Inspector
Attachment #804798 - Flags: review?(dcamp) → review+
Can we land that?
Orange
An additional change was needed to resolve a race condition.  Currently, when a toolbox is destroyed, the panels, host, and target are all told to destroy and they race each other. 

The complication is that the inspector panel wants to destroy the WalkerFront / WalkerActor and the target now wants to destroy the InspectorFront (which owns the WalkerFront) and the debugger connection (for local tabs only).

In this version, I've made an additional change to delay target destruction until after the panels and host are done being destroyed, in case they rely on an active connection to do their work.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=5112236ade3b
Attachment #804798 - Attachment is obsolete: true
Attachment #805486 - Flags: review?(dcamp)
Whiteboard: [needed-in-aurora-26]
Attachment #805486 - Flags: review?(dcamp) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fd81593030b1
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 805486 [details] [diff] [review]
Clean up inspector front and actor when reusing connection (v2)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: can't use the inspector twice
Testing completed (on m-c, etc.): fx-team, m-c
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: no
Attachment #805486 - Flags: approval-mozilla-aurora?
Attachment #805486 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101 Firefox/28.0

The issue as described in Comment 0 still reproduces on latest Nightly (20131030030201) on Debugger tab.

Using the following STR it can also be seen in the Inspector tab:
1. Open an app
2. Select the Debug button
3. On toolbox select all the tabs and check that they contain data
4. Go to Console tab and close the toolbox
5. Reopen the toolbox and check again the tabs content

AR: The Inspector and Debugger tabs have no content. Please see the screencast: https://docs.google.com/file/d/0BzbDkQ2Zlg86ZklJaDZWZUNoUkk/edit?usp=sharing

Should I file new bugs for these issues? Thanks
QA Contact: petruta.rasa
(In reply to petruta.rasa from comment #10)
> Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101
> Firefox/28.0
> 
> The issue as described in Comment 0 still reproduces on latest Nightly
> (20131030030201) on Debugger tab.
> 
> Using the following STR it can also be seen in the Inspector tab:
> 1. Open an app
> 2. Select the Debug button
> 3. On toolbox select all the tabs and check that they contain data
> 4. Go to Console tab and close the toolbox
> 5. Reopen the toolbox and check again the tabs content
> 
> AR: The Inspector and Debugger tabs have no content. Please see the
> screencast:
> https://docs.google.com/file/d/0BzbDkQ2Zlg86ZklJaDZWZUNoUkk/edit?usp=sharing
> 
> Should I file new bugs for these issues? Thanks

Yes. Please. That sounds pretty bad.
Marking as verified since the original issue is not reproducible on latest Aurora (20131028004004) and Nightly (20131030030201). Logged 933212 and 933214 for the other issues found.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.