Last Comment Bug 915497 - Disable oomAfterAllocations while doing minor collections
: Disable oomAfterAllocations while doing minor collections
Status: RESOLVED DUPLICATE of bug 914614
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: general
: general
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 912928
  Show dependency treegraph
 
Reported: 2013-09-11 20:17 PDT by Terrence Cole [:terrence]
Modified: 2013-09-27 10:48 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Terrence Cole [:terrence] 2013-09-11 20:17:35 PDT
Minor GC does not handle OOM gracefully. This is fine because OOM is rare and the failure path is just a MOZ_CRASH. This does, however, make any OOM tests that use oomAfterAllocations interact poorly with GGC. It should be fine to just ignore oomAfterAllocations when doing a minor GC, since that is not the failure path that oomAfterAllocations wants to test.
Comment 1 User image Terrence Cole [:terrence] 2013-09-27 10:48:07 PDT
We needed this mechanism in bug 914614, so I added it there, with a testcase.

*** This bug has been marked as a duplicate of bug 914614 ***

Note You need to log in before you can comment on or make changes to this bug.