Defect - Download progress quickly flashes as "completed" and then starts the download progress

VERIFIED FIXED in Firefox 28

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: sfoster)

Tracking

unspecified
Firefox 28
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

(Whiteboard: [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1 [next-aurora-uplift])

Attachments

(1 attachment)

Reporter

Description

6 years ago
Sometimes when you wait about 2 seconds before selecting "Save" during a download, you'll notice that the entire download progress will appear blue and then quickly start displaying the correct progress. This appears as a quick "flash".

This usually happens on smaller downloads like the VLC executable. Reproduced this pretty consistently.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to http://get.videolan.org/vlc/2.0.8/win32/vlc-2.0.8-win32.exe
3) The download will start counting down and the download app bar should slide into view from the bottom
4) Once the download app bar slides into view with the "Save" option, wait 2 seconds and then select "Save". Notice the the download progress circle will flash completely blue and then return to the correct progress

Current Behavior:

- The download progress indicator quickly flashes blue and appears as the download was completed and then quickly starts displaying the correct progress

Expected Behavior:

- The download progress circle should appear "fully" blue as this makes it seem as the download was completed and then quickly starts showing the correct progress

Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-11-03-02-58-mozilla-central/
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [preview-triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Summary: Defect - Download progress quickly flashes as "completed" and then starts the download progress → [MP] Defect - Download progress quickly flashes as "completed" and then starts the download progress
No longer blocks: MetroPreviewRelease
Summary: [MP] Defect - Download progress quickly flashes as "completed" and then starts the download progress → Defect - Download progress quickly flashes as "completed" and then starts the download progress
Whiteboard: [preview-triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [release28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Assignee: nobody → sfoster
Blocks: metrov1it21
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [release28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Whiteboard: [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1
Assignee

Comment 1

6 years ago
We had a race condition in updateProgress while the image was still loading. This patch rearranges that logic so the canvas operations only take place when that image has completed loading. Also catches a corner case where we might reset while the image is loading. 

updateProgress method still returns [startAngle, endAngle] whether it renders or not.
Attachment #8345495 - Flags: review?(rsilveira)
Comment on attachment 8345495 [details] [diff] [review]
Fix image loading/rendering logic in circular-progress-indicator binding

Review of attachment 8345495 [details] [diff] [review]:
-----------------------------------------------------------------

looks good.
Attachment #8345495 - Flags: review?(rsilveira) → review+
Assignee

Comment 3

6 years ago
Landed on fx-team: 
https://hg.mozilla.org/integration/fx-team/rev/9c4075d7e10c

also, adding [next-aurora-uplift] to whiteboard for uplift batching.
Whiteboard: [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1 → [beta28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1 [next-aurora-uplift]
https://hg.mozilla.org/mozilla-central/rev/9c4075d7e10c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Comment on attachment 8345495 [details] [diff] [review]
Fix image loading/rendering logic in circular-progress-indicator binding

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown

User impact if declined: polish issue in the initial display of the download progress indicator in Metro.

Testing completed (on m-c, etc.): Landed on m-c on 12/11.

Risk to taking this patch (and alternatives if risky): Very low-risk Metro-only patch.

String or IDL/UUID changes made by this patch: None.
Attachment #8345495 - Flags: approval-mozilla-aurora?
Attachment #8345495 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

6 years ago
Target Milestone: Firefox 29 → Firefox 28
Reporter

Comment 7

6 years ago
Went through the following defect for iteration #20 without any issues. Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-28-03-02-04-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-29-00-40-02-mozilla-aurora/

- Went through the original test case from comment #0 without any issues
- Downloaded several small files and made sure that the race condition didn't occur this time around
- Downloaded several large files and made sure that the race condition didn't occur this time around
- Downloaded several different files (EXE, PDF, JPG, BMP) without the original issue occurring
- Ensured that all of the above test cases worked while in filled view
- Ensured that all of the above test cases worked while in snapped view
Reporter

Updated

6 years ago
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.