Closed Bug 915575 Opened 8 years ago Closed 8 years ago

For gaia endurance test cases: Should keep the data and saved in the file system

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 915572

People

(Reporter: mdas, Unassigned)

Details

This is needed by the Taipei team running MTBF endurance tests.

To be specific, Bruce, does this mean to keep all the data we wipe during the setUp/cleanUp phase in gaia-ui-test (https://github.com/mozilla/gaia-ui-tests/blob/master/gaiatest/gaia_test.py#L425 and https://github.com/mozilla/gaia-ui-tests/blob/master/gaiatest/gaia_test.py#L452)? From what I can see here, we remove contact information, media files, indexedDB files, /data/b2g/mozilla (profile information).
Is this a duplicate of bug 915572 where we'll be leaving the data between tests, or do you want to clear the data from the target but have it backed up somewhere?
Flags: needinfo?(bweng)
Hi David,

I believe we should leave the data between tests and not to clean up the data as to simulate the real user's usage. 

Thanks.
Flags: needinfo?(bweng)
Okay, that sounds like a duplicate of bug 915572 then, which proposes to add a --no-cleanup argument to avoid any cleanup between tests.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915572
You need to log in before you can comment on or make changes to this bug.