HTML text following "<![" isn't displayed

VERIFIED DUPLICATE of bug 130045

Status

()

Core
HTML: Parser
--
enhancement
VERIFIED DUPLICATE of bug 130045
17 years ago
16 years ago

People

(Reporter: Koike Kazuhiko, Assigned: harishd)

Tracking

({compat})

Trunk
Future
x86
All
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX ? -- non standards compliant)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
HTML text following "<![" isn't displayed. it can't be closed
with "-->".

<ol>
<li>Moz<!commnet -->illa</li>
<li>Moz<! [comment] -->illa</li>
<li>Moz<![comment] -->illa</li>
<li>Mozilla</li>
</ol>

This is displayed as:

1. Mozilla
2. Mozilla
3. Moz
(Reporter)

Comment 1

17 years ago
Created attachment 42942 [details]
Testcase
Is this a bug?
Assignee: clayton → harishd
Component: HTML Element → Parser
Your source is WAAAY invalid. Our behaviour is well within the bounds of the
spec, and is arguably better than IE's.

Marking INVALID.
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: compat
Resolution: --- → INVALID
Whiteboard: WONTFIX ? -- non standards compliant
Target Milestone: --- → Future

Updated

16 years ago
QA Contact: bsharma → moied

Comment 4

16 years ago
Reopening in order to dupe with the case I made in bug 130045
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 130045 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Verified dup of 130045 

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.