bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Buri] Unable to flash a build due to running out of disk space

RESOLVED WONTFIX

Status

Firefox OS
GonkIntegration
RESOLVED WONTFIX
5 years ago
5 months ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SUMO])

(Reporter)

Description

5 years ago
I was trying to flash gecko and gaia with today's nightly images, and the device says the images are running out of space.

Regression range:  this worked against Sept 11th images, but broke on Sept 12th image.

Log:
------
host-2-36:09122013_hamachi_12 tchung$ ./fullflash_gecko_ril_gaia.sh 
+ gaining root access
adbd is already running as root
+ Waiting for adb to come back up
+ remounting the system partition
remount succeeded
+ Waiting for adb to come back up
+ Stopping b2g
+ Installing new b2g
push: b2g/components/components.manifest -> /system/b2g/components/components.manifest
push: b2g/dictionaries/en-US.dic -> /system/b2g/dictionaries/en-US.dic
push: b2g/dictionaries/en-US.aff -> /system/b2g/dictionaries/en-US.aff
push: b2g/updater -> /system/b2g/updater
push: b2g/Throbber-small.gif -> /system/b2g/Throbber-small.gif
push: b2g/run-mozilla.sh -> /system/b2g/run-mozilla.sh
push: b2g/removed-files -> /system/b2g/removed-files
push: b2g/precomplete -> /system/b2g/precomplete
push: b2g/plugin-container -> /system/b2g/plugin-container
push: b2g/platform.ini -> /system/b2g/platform.ini
push: b2g/omni.ja -> /system/b2g/omni.ja
push: b2g/libxul.so -> /system/b2g/libxul.so
push: b2g/libsoftokn3.so -> /system/b2g/libsoftokn3.so
push: b2g/libnssckbi.so -> /system/b2g/libnssckbi.so
push: b2g/libnss3.so -> /system/b2g/libnss3.so
push: b2g/libmozglue.so -> /system/b2g/libmozglue.so
push: b2g/libfreebl3.so -> /system/b2g/libfreebl3.so
push: b2g/dependentlibs.list -> /system/b2g/dependentlibs.list
push: b2g/crashreporter.ini -> /system/b2g/crashreporter.ini
push: b2g/chrome.manifest -> /system/b2g/chrome.manifest
push: b2g/b2g -> /system/b2g/b2g
push: b2g/application.ini -> /system/b2g/application.ini
22 files pushed. 0 files skipped.
3899 KB/s (33083397 bytes in 8.284s)
+ Uninstalling old RIL
rm failed for /system/b2g/distribution/bundles/libqc_b2g_location, No such file or directory
rm failed for /system/b2g/distribution/bundles/libqc_b2g_ril, No such file or directory
+ Installing new RIL
cannot stat 'ril': No such file or directory
+ Removing incompatible extensions
+ Done installing gecko and RIL!
+ Adjusting user.js
+ Deleting any old gaia and profiles
rm failed for /cache/lost+found, Directory not empty
rm failed for /data/local/user.js, No such file or directory
+ Installing new gaia webapps
push: gaia/profile/webapps/bluetooth.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/bluetooth.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/bluetooth.gaiamobile.org/application.zip -> /system/b2g/webapps/bluetooth.gaiamobile.org/application.zip
push: gaia/profile/webapps/browser.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/browser.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/browser.gaiamobile.org/application.zip -> /system/b2g/webapps/browser.gaiamobile.org/application.zip
push: gaia/profile/webapps/calendar.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/calendar.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/calendar.gaiamobile.org/application.zip -> /system/b2g/webapps/calendar.gaiamobile.org/application.zip
push: gaia/profile/webapps/camera.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/camera.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/camera.gaiamobile.org/application.zip -> /system/b2g/webapps/camera.gaiamobile.org/application.zip
push: gaia/profile/webapps/clock.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/clock.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/clock.gaiamobile.org/application.zip -> /system/b2g/webapps/clock.gaiamobile.org/application.zip
push: gaia/profile/webapps/communications.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/communications.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/communications.gaiamobile.org/application.zip -> /system/b2g/webapps/communications.gaiamobile.org/application.zip
push: gaia/profile/webapps/costcontrol.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/costcontrol.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/costcontrol.gaiamobile.org/application.zip -> /system/b2g/webapps/costcontrol.gaiamobile.org/application.zip
push: gaia/profile/webapps/email.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/email.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/email.gaiamobile.org/application.zip -> /system/b2g/webapps/email.gaiamobile.org/application.zip
push: gaia/profile/webapps/fm.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/fm.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/fm.gaiamobile.org/application.zip -> /system/b2g/webapps/fm.gaiamobile.org/application.zip
push: gaia/profile/webapps/gallery.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/gallery.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/gallery.gaiamobile.org/application.zip -> /system/b2g/webapps/gallery.gaiamobile.org/application.zip
push: gaia/profile/webapps/homescreen.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/homescreen.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/homescreen.gaiamobile.org/application.zip -> /system/b2g/webapps/homescreen.gaiamobile.org/application.zip
push: gaia/profile/webapps/keyboard.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/keyboard.gaiamobile.org/manifest.webapp
push: gaia/profile/webapps/keyboard.gaiamobile.org/application.zip -> /system/b2g/webapps/keyboard.gaiamobile.org/application.zip
failed to copy 'gaia/profile/webapps/keyboard.gaiamobile.org/application.zip' to '/system/b2g/webapps/keyboard.gaiamobile.org/application.zip': No space left on device
host-2-36:09122013_hamachi_12 tchung$ 


REpro:
1) save gaia.zip and b2g-26.0a1.en-US.android-arm.tar.gz from https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi/latest/.
* b2g-26.0a1.en-US.android-arm.tar.gz	12-Sep-2013 12:55 	19M	 
* gaia.zip	12-Sep-2013 12:55 	41M	 
2) device info
root@android:/ # df
Filesystem             Size   Used   Free   Blksize
/dev                    90M    48K    90M   4096
/mnt/asec               90M     0K    90M   4096
/mnt/obb                90M     0K    90M   4096
/system                200M   197M     2M   4096
/data                  161M    60M   100M   4096
/persist                 4M   908K     3M   4096
/cache                  40M     1M    38M   4096
3) run ./fullflash_gecko_ril_gaia.sh, which flashes only gecko and gaia from the zip files
4) Verify unable to install due to losing disk space:

"failed to copy 'gaia/profile/webapps/keyboard.gaiamobile.org/application.zip' to '/system/b2g/webapps/keyboard.gaiamobile.org/application.zip': No space left on device"

Expected
- keyboard packages is smaller, so everything can flash.  

ActuaL
- can't flash due to losing disk space
(Reporter)

Comment 1

5 years ago
Not sure who owns this.  John, can you help me get this bug directed to the right place?
Flags: needinfo?(joduinn)
Dave, can you help Tony with this?
Flags: needinfo?(dhylands)
I reproduced the same thing.

I discovered that there was a failed update sitting in /system/b2g/update

So I'd recommend that you add:

adb shell rm -r /system/b2g/update

before trying to push files.

Actually, I think that you should rm -rf /system/b2g (which will remove all of the b2g files as well as all of the webapps).

Then install the new stuff.
Flags: needinfo?(dhylands)
(Reporter)

Comment 4

5 years ago
(In reply to Dave Hylands [:dhylands] from comment #3)
> I reproduced the same thing.
> 
> I discovered that there was a failed update sitting in /system/b2g/update
> 
> So I'd recommend that you add:
> 
> adb shell rm -r /system/b2g/update
> 
> before trying to push files.
> 
> Actually, I think that you should rm -rf /system/b2g (which will remove all
> of the b2g files as well as all of the webapps).
> 
> Then install the new stuff.

this seemed to work, thanks Dave.  but will FOTA users ever hit this in the wild?   they will never be doing rm -r /system/b2b/update.

Tony
Only OTA users should ever have /system/b2g/update.

Pure FOTA users would never get that directory created in the first place.
(Reporter)

Comment 6

5 years ago
(In reply to Dave Hylands [:dhylands] from comment #5)
> Only OTA users should ever have /system/b2g/update.
> 
> Pure FOTA users would never get that directory created in the first place.

removing koi? since dave answered the question about OTA, and this doesnt affect FOTA locations.
blocking-b2g: koi? → ---
Flags: needinfo?(joduinn)
I'm running into this while trying to flash a debug noopt Gecko to the device. Is there a way I can increase the size of the /system partition?
Hi, I had the same problem but when I try to run adb shell it says that /system/b2g is read-only.

What should I do?
Guys, I followed this instructions: 
    adb root
    adb shell mount -o remount,rw /system
    adb shell rm -r /system/b2g/
    adb shell mount -o remount,ro /system
    adb shell sync && adb reboot
and I fixed it.

My problem as different as yours, are because when I tried to push gaia it says that I had no space left to complete the push. 

Thanks

Comment 10

4 years ago
I encountered the same issue on Flame device, when I tried to push gaia it says that I had no space left to complete the push. So I followed the steps provided by  Sebastián Enrique Becerra Cancino and it worked.

Updated

4 years ago
Whiteboard: [SUMO]

Comment 11

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.