Closed Bug 916166 Opened 6 years ago Closed 6 years ago

[app manager] Disable the network monitor

Categories

(DevTools :: WebIDE, defect)

x86
All
defect
Not set

Tracking

(firefox26 verified, firefox27 verified)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified

People

(Reporter: paul, Assigned: paul)

References

Details

Attachments

(1 file)

It doesn't work.
Neither the Network logging the Console. Should we disable that as well? How hard would it be to fix this? Mihai?
Flags: needinfo?(mihai.sucan)
I talked to Paul in Paris about the problems with network logging.

1. network requests happen in the main process, not in content processes where the content actors work (including the console actor). So, we don't see any requests.

2. network requests in the main process have no associatedWindow property. The global console actor will show all network requests, from the entire system, without being able to filter them based on windows or apps.

We need a solution to have the toolbox connect to the global console actor and get the network requests for the app that the toolbox is attached to. Or we needed the content console actor to talk to the main process to get the network requests associated to the content process. ( i prefer the latter approach )

This needs platform work. Do we have an open bug for finding a solution?
Flags: needinfo?(mihai.sucan)
See bug 917227 for solving the Network monitor problem. In the meantime, we need to disable it.
Whiteboard: [needed-in-aurora-26]
Attached patch Patch v1Splinter Review
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #806001 - Flags: review?(poirot.alex)
Comment on attachment 806001 [details] [diff] [review]
Patch v1

Review of attachment 806001 [details] [diff] [review]:
-----------------------------------------------------------------

No more network panel on remote apps, still one on local tabs, looks good!
Attachment #806001 - Flags: review?(poirot.alex) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6d99c3c606ae
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 806001 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: useless tool available to the user
Testing completed (on m-c, etc.): fx-team, m-c
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: no
Attachment #806001 - Flags: approval-mozilla-aurora?
Attachment #806001 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 - Network Monitor and Scratchpad disabled.
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 - Network Monitor disabled.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Also verified on Mac OS X 10.8.4 and Windows 7 64bit on the same versions (except for Aurora on Windows - I couldn't get connected to the Simulator there no matter what I did).
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.