[B2G][Buri][1.2][Camera]Camera viewfinder freezes when attempting to record a video, no video is saved.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: jzimbrick, Assigned: sotaro)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox25 wontfix, firefox26 fixed, firefox27 verified, b2g-v1.2 verified)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Description:
 When attempting to a record a video in the camera app, the viewfinder freezes shortly after pressing the record button.  The video time continues to increase, but no video is saved after pressing stop.

Repro Steps:
1. Update Buri device to moz 1.2 build 20130913040201.
2. Open the camera app.
3. Press the Video camera button in the bottom right to switch to video record mode.
4. Tap the record button centered at the bottom of the screen.
5. Observe that the viewfinder freezes shortly after tapping the record button, the video timer continues counting up, and after tapping the button to stop recording, no video is saved.

Actual:
 The camera viewfinder freezes shortly after attempting to record. The video timer continues counting up, and after tapping the button to stop recording, no video is saved.

Expected:
 The viewfinder displays what is being recorded, tapping the stop button saves a video.

Environmental Variables
Build ID: 20130913040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/b9029b1de410
Gaia: 8ccb741b6adcfe9a78b842c17e5874242c0f8b86
Platform Version: 26.0a1
Base Image: 20130912

Notes:
Repro frequency: 100%
See attached: logcat

We are also seeing https://bugzilla.mozilla.org/show_bug.cgi?id=828600 in connection with this issue, the record symbol appears in the status bar and lingers for quite some time.
QA Contact: sparsons
This issue started to occur on today's Buri 1.2 Build ID: 20130913040201, checked builds from 9/02-9/12

Build ID: 20130913040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/b9029b1de410
Gaia: 8ccb741b6adcfe9a78b842c17e5874242c0f8b86
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043 
Base Image: 20130912
Assignee: nobody → sotaro.ikeda.g
Sorry, Bug 871364 made this regression.
The patch fix the encoder flags to be same as before Bug 871364. Confirmed the patch fix the video recording problem on hamachi.
Attachment #805018 - Flags: review?(mhabicher)
Attachment #805018 - Flags: review?(mhabicher) → review+
Committable patch. Carry "mhabicher: review+".
Attachment #805018 - Attachment is obsolete: true
Attachment #805341 - Flags: review+
Keywords: checkin-needed
Attachment #804579 - Attachment is obsolete: true
Relmgmt, we need this koi+'d.   This is a smoketest blocker.
Flags: needinfo?(praghunath)
Component: Gaia::Camera → General
Confirmed--this fixes the issue.
koi+
blocking-b2g: koi? → koi+
https://hg.mozilla.org/mozilla-central/rev/d3d07b3134ca
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Issue no longer appears to be occurring in today's 1.2 moz build.

Environmental  Variables:
Build ID: 20130917180029
Gecko: http://hg.mozilla.org/mozilla-central/rev/53a2011a01b2
Gaia: 678c1d23150b0b9b037de9b2122fcccd75bdb6f5
Platform Version: 27.0a1

User is able to record video as normal, the viewfinder does not freeze. After pressing stop, a video is saved, and it can be played back without issue in the video app.

Verifying as fixed.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 918907
Duplicate of this bug: 912957
This issue no longer reproduces on Buri v 1.3 master and v 1.2 aurora 10/15 build.

User is able to record the video, the viewfinder does not freeze. After pressing stop, a video is saved, and it can be played back without any issue in the video app.

Environmental Variables
Device: Buri v 1.3.0 master Mozilla RIL
Build ID: 20131015040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/febfe3c7732b
Gaia: 17e871ae1f82699793e3cd28acda805ba724a8b6
Platform Version: 27.0a1
Firmware Version: US_20130912_QC211


v 1.2 aurora 10/15 build

Environmental Variables
Device: Buri v 1.2.0 aurora Mozilla RIL
Build ID: 20131015004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/f80fd27d367f
Gaia: 94e3088c56c7348655ae76613defd126426cc722
Platform Version: 26.0a2
Firmware Version: US_20130912_QC211
Flags: needinfo?(praghunath)
You need to log in before you can comment on or make changes to this bug.