[MP] Defect - external links open on desktop rather than metro UI

VERIFIED FIXED in Firefox 26

Status

P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: kpoirot, Assigned: bbondy)

Tracking

({regression})

26 Branch
Firefox 27
All
Windows 8.1
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox26+ fixed, firefox27 fixed)

Details

(Whiteboard: [preview] feature=defect c=install_and_setup u=metro_firefox_user p=1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130913030201

Steps to reproduce:

STR :

open mail app from metro

find a http or https link in your mails and click on it

firefox metro don't open
check on the desktop, nightly opened there


Actual results:

nothing happens
firefox metro don't open (while it is set as default browser)
if you check the desktop, nightly opened the link there


Expected results:

the link should open into nightly metro
(Reporter)

Updated

5 years ago
OS: All → Windows 8 Metro

Updated

5 years ago
Blocks: 838081
Summary: external links open on desktop rather than metro UI → Defect - external links open on desktop rather than metro UI
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0

Comment 1

5 years ago
This is a recent regression I can reproduce on the 9/15 nightly build on Windows 8.0 and 8.1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0

Updated

5 years ago
Blocks: 899390
Summary: Defect - external links open on desktop rather than metro UI → [MP] Defect - external links open on desktop rather than metro UI
(Assignee)

Updated

5 years ago
Blocks: 909637
No longer blocks: 838081
Status: NEW → ASSIGNED
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=1
(Assignee)

Comment 2

5 years ago
Created attachment 805615 [details] [diff] [review]
Patch v1.
Assignee: nobody → netzen

Updated

5 years ago
Priority: -- → P1
QA Contact: jbecerra
(Assignee)

Comment 3

5 years ago
Comment on attachment 805615 [details] [diff] [review]
Patch v1.

bad hresult check
Attachment #805615 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #805615 - Flags: review?(jmathies) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/d7c49f9c66c3
Keywords: checkin-needed
Target Milestone: --- → Firefox 27

Updated

5 years ago
Whiteboard: [preview] feature=defect c=tbd u=tbd p=1 → [preview] feature=defect c=install_and_setup u=metro_firefox_user p=1

Updated

5 years ago
Blocks: 831887
Should we nominate this for Aurora?
status-firefox26: --- → affected
status-firefox27: --- → fixed
tracking-firefox26: --- → ?
Keywords: regression

Comment 6

5 years ago
Yes, we should get this into Aurora for sure.
https://hg.mozilla.org/mozilla-central/rev/d7c49f9c66c3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
tracking-firefox26: ? → +
(Assignee)

Comment 8

5 years ago
Comment on attachment 805615 [details] [diff] [review]
Patch v1.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 882142
User impact if declined: Opening links in the Metro environment will switch to Desktop and open the Desktop browser even if we are the default browser.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #805615 - Flags: approval-mozilla-aurora?
Comment on attachment 805615 [details] [diff] [review]
Patch v1.

We need this uplifted to go into the Aurora builds for tomorrow's unthrottling - approved.
Attachment #805615 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
Tried to land but the aurora tree is closed.
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/c64b37f395e2
status-firefox26: affected → fixed
Keywords: checkin-needed
Verified as fixed with the latest Nightly, for iteration #15,  on both Win 8 32-bit and 64-bit.

After following the STR from comment 0, after clicking a link from my Yahoo email account, it opens in Metro, in a new tab, as expected.
Status: RESOLVED → VERIFIED
> Verified as fixed with the latest Nightly, for iteration #15,  on both Win 8
> 32-bit and 64-bit.
> 
> After following the STR from comment 0, after clicking a link from my Yahoo
> email account, it opens in Metro, in a new tab, as expected.

Also verified with latest Aurora, build ID: 20131002004002, on both Win 8 32-bit and 64-bit.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.