Closed Bug 916237 Opened 7 years ago Closed 7 years ago

Inspector won't connect to non-OOP B2G apps

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(firefox26 verified, firefox27 verified, b2g-v1.2 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified
b2g-v1.2 --- fixed

People

(Reporter: jryans, Assigned: ochameau)

References

Details

Attachments

(1 file)

STR:

1. Use the App Manager to connect a non-OOP app, like System
2. Go to the Inspector tab
3. It is blank
4. You have the following error in the Browser Console:

this.conn.allocID is not a function

Pool<.manage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:689
exports.InspectorFront<.initialize@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/inspector.js:2245
constructor@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/core/heritage.js:145
TabTarget.prototype.inspector@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/target.js:263
InspectorPanel.prototype._getWalker@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/inspector/inspector-panel.js:150
InspectorPanel_open/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/inspector/inspector-panel.js:49
resolve@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/core/promise.js:118
then@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/core/promise.js:43
then@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/core/promise.js:153
InspectorPanel_open@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/inspector/inspector-panel.js:48
Tools.inspector.build@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/main.js:113
TBOX_loadTool/onLoad@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:518
The style editor either.
Might be related: bug 915444
I tried out the patch from bug 915444 on B2G, but that didn't appear to resolve the issue for me.
The exceptiong really didn't help figuring out this simple issue...
We weren't loading inspector actor in the parent process, so that any app being debugged in parent process wasn't having the inspector tab actor instanciated.
Comment on attachment 805382 [details] [diff] [review]
Enable inspector actor in b2g parent process r=paul

It also fix the inspector in the simulator as all apps are still in parent process.
Attachment #805382 - Flags: review?(paul)
Assignee: nobody → poirot.alex
Attachment #805382 - Flags: review?(paul) → review+
Keywords: checkin-needed
Whiteboard: [land-in-fx-team]
Whiteboard: [land-in-fx-team] → [land-in-fx-team], [needed-in-aurora-26]
https://hg.mozilla.org/integration/fx-team/rev/6873763660a5
Whiteboard: [land-in-fx-team], [needed-in-aurora-26] → [needed-in-aurora-26]
Keywords: checkin-needed
Blocks: 915258
https://hg.mozilla.org/mozilla-central/rev/6873763660a5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 805382 [details] [diff] [review]
Enable inspector actor in b2g parent process r=paul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: Not possible to use the inspector with some Firefox OS apps
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: no
Attachment #805382 - Flags: approval-mozilla-aurora?
Attachment #805382 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [needed-in-aurora-26] → [land-in-aurora-26]
Keywords: verifyme
I am unable to reproduce the initial issue. Can you please verify that this is fixed on latest Aurora and latest Nightly?
Flags: needinfo?(jryans)
Yes, it is fixed in the latest Aurora and Nightly.
Flags: needinfo?(jryans)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.