Closed Bug 916258 Opened 8 years ago Closed 8 years ago

Stop running t-canvasmark on Pandas

Categories

(Release Engineering :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philor, Assigned: Callek)

References

Details

(Whiteboard: [capacity])

Attachments

(1 file)

https://tbpl.mozilla.org/?showall=1&rev=a4e9c9c9dbf9&jobname=canvasmark

<jmaher> philor: awesome, we really should turn that off for panda boards

That one, currently at 30+ hours and still trying to get green, is exceptional but not by that much; typically they either take six or seven tries to get green, or take six or seven tries and then fall off the bottom of the page so I don't retrigger the reds any more.
adding a bunch of guys to the cc line- if there is no logical explanation for this then turning it off would be good to stop chewing up dozens of panda boards an hour.
The loss of connectivity looks like what we saw on robocop-on-panda when jobs were taking too long. But I have no idea why the test is usually taking > 60 minutes and occasionally finishing in 15 minutes.
I looked into this locally, the panda seems to be doing a soft restart as all processes are killed and started up again.  We have a high RSS reading 205MB+ during the test, I suspect we are starving the OS of resources.

According to graph server we are getting data posted for this test quite frequently.
kats -- The log in Comment 4 has a lot of debug messages: "Aborting update due to viewport not in display-port". Is that anything to worry about? Does it tell us anything useful?
Flags: needinfo?(bugmail.mozilla)
and a second run for pattern detection:
http://people.mozilla.org/~jmaher/tcanvasmark2.logcat

along with the traces.txt file:
http://people.mozilla.org/~jmaher/traces2.txt  (keep in mind this was after a reboot since the device was not accessible after the "soft reboot")
In both of the logs, "[Test 2 - Asteroids - Vectors]" is the last GeckoConsole message before it becomes obvious that the system is in trouble. I wonder if canvasmark would pass without Test 2?


From the first log (Comment 4):

09-16 19:23:40.257 E/GeckoConsole( 2077): 1112 [Test 2 - Asteroids - Vectors]
...
09-16 19:26:11.648 W/ActivityManager( 1425): Timeout of broadcast BroadcastRecord{414e9cf0 android.intent.action.TIME_TICK} - receiver=android.os.BinderProxy@41368478, started 11613ms ago
09-16 19:26:11.648 I/SUTAgentAndroid( 1938): 192.168.1.70 : isdir /mnt/sdcard/tests
09-16 19:26:11.648 W/ActivityManager( 1425): Receiver during timeout: BroadcastFilter{41368808 ReceiverList{41368790 1523 com.android.systemui/1000 remote:41368478}}
09-16 19:26:11.656 I/Process ( 1425): Sending signal. PID: 1523 SIG: 3
09-16 19:26:11.656 I/dalvikvm( 1523): threadid=3: reacting to signal 3
09-16 19:26:11.656 I/dalvikvm( 1523): Wrote stack traces to '/data/anr/traces.txt'
09-16 19:26:11.656 I/Process ( 1425): Sending signal. PID: 1425 SIG: 3
09-16 19:26:11.656 I/dalvikvm( 1425): threadid=3: reacting to signal 3
09-16 19:26:11.656 W/ActivityManager( 1425): finishReceiver called but no pending broadcasts


From the second log (Comment 6):

09-16 20:12:34.443 E/GeckoConsole( 3439): 1214 [Test 2 - Asteroids - Vectors]
...
09-16 20:12:49.693 W/dalvikvm( 1952): threadid=21: spin on suspend #1 threadid=14 (pcf=0)
09-16 20:12:49.693 W/dalvikvm( 1952): threadid=21: spin on suspend #2 threadid=14 (pcf=0)
09-16 20:12:49.693 I/dalvikvm( 1952): "CmdWorkerThread" prio=5 tid=21 RUNNABLE
(In reply to Geoff Brown [:gbrown] from comment #5)
> kats -- The log in Comment 4 has a lot of debug messages: "Aborting update
> due to viewport not in display-port". Is that anything to worry about? Does
> it tell us anything useful?

It is something to worry about, but it looks like a result of errors earlier in the log. The first error is at 19:20:16.851 when it dumps the anr trace for no reason. There's also an error at 19:20:28.632 that is somewhat worrisome although that's just after a System.exit() so maybe that's ok? It's hard to tell what's going on from the log - it looks like fennec gets run multiple times even though (I assume) it's a single talos run. It would be better if possible to do a logcat -c before the run and then get the full log from the talos run.

(In reply to Joel Maher (:jmaher) from comment #6)
> and a second run for pattern detection:
> http://people.mozilla.org/~jmaher/tcanvasmark2.logcat

Much the same here.

> along with the traces.txt file:
> http://people.mozilla.org/~jmaher/traces2.txt  (keep in mind this was after
> a reboot since the device was not accessible after the "soft reboot")

This traces file doesn't have any fennec code listed.
Flags: needinfo?(bugmail.mozilla)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> (In reply to Geoff Brown [:gbrown] from comment #5)
> It's hard to tell what's going on from the log - it looks like fennec gets
> run multiple times even though (I assume) it's a single talos run. 

Talos page load tests launch the browser with the getInfo page, then close the browser and re-open it with the test page. I think that's all that you are seeing here.
I am not sure how to turn these off for pandas, now that we are in mozharness land, the configs might be different?  Also we want these running for tegras.

Kim, do you know how to disable tcanvasmark for the pandas only?
Flags: needinfo?(kmoir)
I tried a few things to implement this and none of them worked.  I talked to aki and he said that it's difficult to do right now because it can only be disabled on a per branch basis.

A quick and dirty fix would be to remove the tcanvasmark options from the panda talos script and then hide the test.  The test would be scheduled but fail due to missing options.
Flags: needinfo?(kmoir)
I have hidden them from m-c and m-i.  I suspect there are other branches we should hide them on as well.  I am open to removing the options from the builder in mozharness so it fails faster.
I would not call that a win: I watch &showall=1 on every tree except b2g-inbound, because we have tons of things which despite being hidden shouldn't be broken more than they already are. Having a permanently permared job with no chance that it would ever be fixed would be... unsatisfactory.
well, there is no way to disable this on pandas only.  As long as we do retry/retrigger these for panda boards that will be good.  I am open to other solutions?  Possibly not running these at all?  

Blassey: does tcanvasmark provide much value on the tegra hardware vs the panda hardware?
Flags: needinfo?(blassey.bugs)
Are you asking if having it run on both is useful? If so, then yes. Panda's have different hardware and OS version which can lead to perf differences that are important.

That said, I wouldn't be opposed to turning it off on pandas while we get this figured out to save the load.
Flags: needinfo?(blassey.bugs)
I already told Joel but worth noting here as well: I looked into this a couple weeks ago and was unable to reproduce on my local panda. Hopefully I can get back to it at some point, but if we need to disable it in the mean time I understand.
Assignee: nobody → bugspam.Callek
Status: NEW → ASSIGNED
Attachment #8342532 - Flags: review?(armenzg)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #16)
> I already told Joel but worth noting here as well: I looked into this a
> couple weeks ago and was unable to reproduce on my local panda. Hopefully I
> can get back to it at some point, but if we need to disable it in the mean
> time I understand.

When you have time to work on it, please file a loan request bug https://wiki.mozilla.org/ReleaseEngineering/How_To/Request_a_slave
Attachment #8342532 - Flags: review?(armenzg) → review+
checked in and in production.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I was able to reproduce this just now. It got to test 4 and then some unknown badness causes the systemui process to take a dump. It actually looks like memory usage might be ok. I think we'd seem some messages about that otherwise.

I would say it's likely that the SkiaGL stuff is tickling some OpenGL driver bug and we are crashing the gpu, which hangs the systemui process. Bummer. Maybe we should disable SkiaGL on PVR and re-enable this test...

I/ActivityManager( 1427): START {act=android.intent.action.VIEW dat=http://www.kevs3d.co.uk/dev/canvasmark/?auto=true flg=0x10000000 pkg=org.mozilla.fennec cmp=org.mozilla.fennec/.App} from pid 2130
E/GeckoConnectivityReceiver( 2029): Registering receiver failed
W/OrientationEventListener( 2029): Cannot detect sensors. Not enabled
D/GeckoToolbar( 2029): onTabChanged: ADDED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: ADDED
D/GeckoToolbar( 2029): onTabChanged: SELECTED
D/GeckoToolbar( 2029): setFavicon(null)
D/GeckoToolbar( 2029): setProgressVisibility: true
I/GeckoToolbar( 2029): zerdatime 197001 - Throbber start
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: SELECTED
D/AndroidRuntime( 2130): Shutting down VM
D/GeckoToolbar( 2029): onTabChanged: UNSELECTED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 0: UNSELECTED
I/AndroidRuntime( 2130): NOTE: attach of thread 'Binder Thread #3' failed
D/dalvikvm( 2130): GC_CONCURRENT freed 102K, 81% free 487K/2560K, paused 1ms+0ms
D/dalvikvm( 2130): Debugger has detached; object registry had 1 entries
V/GeckoHealthRec( 2029): Recorded session entry for env 1, current is 1
D/GeckoSessInfo( 2029): Recording session done: 1386796296334
D/GeckoBrowserProvider( 2029): Expiring history.
D/GeckoBrowserProvider( 2029): Expiring thumbnails.
D/GeckoSessInfo( 2029): Recording start of session: 1386796336304
I/GeckoHealth( 2029): fennec :: HealthReportBroadcastService :: Registering HealthReportPruneService.
I/GeckoHealth( 2029): fennec :: BackgroundService :: Setting inexact repeating alarm for interval 86400000
D/GeckoTabs( 2029): handleMessage: Tab:Added
D/GeckoTabs( 2029): handleMessage: Link:OpenSearch
D/GeckoTabs( 2029): handleMessage: Content:StateChange
I/IdleService( 2029): next timeout 15000 msec from now
I/IdleService( 2029): SetTimerExpiryIfBefore: next timeout 15000 msec from now
I/IdleService( 2029): reset timer expiry to 15010 msec from now
I/IdleService( 2029): Reset idle timeout: tell observer 68cc7f80 user is back
D/GeckoToolbar( 2029): onTabChanged: MENU_UPDATED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: MENU_UPDATED
D/GeckoToolbar( 2029): onTabChanged: MENU_UPDATED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: MENU_UPDATED
D/GeckoToolbar( 2029): onTabChanged: START
D/GeckoToolbar( 2029): setProgressVisibility: true
I/GeckoToolbar( 2029): zerdatime 197615 - Throbber start
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: START
D/GeckoTabs( 2029): handleMessage: SessionHistory:New
D/GeckoTabs( 2029): handleMessage: Content:LocationChange
D/GeckoTab( 2029): Ignoring location change event: URIs are the same.
D/GeckoTabs( 2029): handleMessage: Content:SecurityChange
D/GeckoToolbar( 2029): onTabChanged: SECURITY_CHANGE
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: SECURITY_CHANGE
D/GeckoTabs( 2029): handleMessage: DOMTitleChanged
D/GeckoToolbar( 2029): onTabChanged: TITLE
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: TITLE
D/dalvikvm( 2029): GC_CONCURRENT freed 363K, 9% free 7537K/8199K, paused 3ms+8ms
E/GeckoConsole( 2029): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://www.kevs3d.co.uk/dev/canvasmark/?auto=true" line: 0}]
D/GeckoTabs( 2029): handleMessage: DOMContentLoaded
D/GeckoToolbar( 2029): onTabChanged: LOADED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: LOADED
D/GeckoTabs( 2029): handleMessage: Tab:ViewportMetadata
D/GeckoToolbar( 2029): onTabChanged: VIEWPORT_CHANGE
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: VIEWPORT_CHANGE
D/GeckoTabs( 2029): handleMessage: Content:PageShow
D/GeckoTabs( 2029): handleMessage: Content:StateChange
D/GeckoToolbar( 2029): onTabChanged: PAGE_SHOW
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: PAGE_SHOW
D/GeckoToolbar( 2029): onTabChanged: STOP
D/GeckoToolbar( 2029): setProgressVisibility: false
D/GeckoToolbar( 2029): setFavicon(null)
D/GeckoToolbar( 2029): Ignoring favicon set: new favicon is identical to previous favicon.
I/GeckoToolbar( 2029): zerdatime 201125 - Throbber stop
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: STOP
E/Profiler( 2029): BPUnw: [6 total] thread_register_for_profiling(me=0xc8be78, stacktop=0x68707e4b)
D/FaviconCache( 2029): Favicon cache fullness: 1024/524288
D/GeckoToolbar( 2029): onTabChanged: FAVICON
D/GeckoToolbar( 2029): setFavicon(android.graphics.Bitmap@412768a8)
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: FAVICON
D/GeckoThumbnailHelper( 2029): Using new thumbnail size: 58240 (width 160)
D/GeckoThumbnailHelper( 2029): Sending thumbnail event: 160, 91
E/Profiler( 2029): BPUnw: [7 total] thread_register_for_profiling(me=0xf9a910, stacktop=0x67703e1f)
D/GeckoThumbnailHelper( 2029): handleThumbnailData: 58240
E/Profiler( 2029): BPUnw: [8 total] thread_register_for_profiling(me=0xf897a0, stacktop=0x679ffd6f)
D/GeckoToolbar( 2029): onTabChanged: THUMBNAIL
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: THUMBNAIL
D/GeckoTabs( 2029): handleMessage: Content:ReaderEnabled
D/GeckoToolbar( 2029): onTabChanged: MENU_UPDATED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: MENU_UPDATED
D/GeckoToolbar( 2029): onTabChanged: READER_ENABLED
D/GeckoBrowserApp( 2029): BrowserApp.onTabChanged: 1: READER_ENABLED
D/dalvikvm( 2029): GC_CONCURRENT freed 297K, 8% free 7625K/8199K, paused 0ms+4ms
E/Profiler( 2029): BPUnw: [7 total] thread_unregister_for_profiling(me=0xf897a0) 
E/GeckoConsole( 2029): 743 [Test 1 - Asteroids - Bitmaps]
I/IdleService( 2029): Get idle time: time since reset 13098 msec
I/IdleService( 2029): Idle timer callback: current idle time 13098 msec
I/IdleService( 2029): next timeout 1900 msec from now
I/IdleService( 2029): SetTimerExpiryIfBefore: next timeout 1900 msec from now
I/IdleService( 2029): reset timer expiry to 1909 msec from now
I/IdleService( 2029): Get idle time: time since reset 15090 msec
I/IdleService( 2029): Idle timer callback: current idle time 15090 msec
I/IdleService( 2029): next timeout 164910 msec from now
I/IdleService( 2029): SetTimerExpiryIfBefore: next timeout 164910 msec from now
I/IdleService( 2029): reset timer expiry to 164920 msec from now
I/IdleService( 2029): Idle timer callback: tell observer 68cc7f80 user is idle
E/GeckoConsole( 2029): 1080 [Test 2 - Asteroids - Vectors]
D/dalvikvm( 2029): GC_CONCURRENT freed 446K, 8% free 7622K/8199K, paused 0ms+5ms
E/GeckoConsole( 2029): 553 [Test 3 - Asteroids - Bitmaps, shapes, text]
E/Profiler( 2029): BPUnw: [6 total] thread_unregister_for_profiling(me=0xc8be78) 
E/Profiler( 2029): BPUnw: [5 total] thread_unregister_for_profiling(me=0xf9a910) 
E/GeckoConsole( 2029): 1508 [Test 4 - Asteroids - Shapes, shadows, blending]
D/dalvikvm( 2029): GC_CONCURRENT freed 446K, 8% free 7622K/8199K, paused 1ms+1ms
W/ActivityManager( 1427): Timeout of broadcast BroadcastRecord{414b9280 android.intent.action.TIME_TICK} - receiver=android.os.BinderProxy@41506f58, started 10015ms ago
W/ActivityManager( 1427): Receiver during timeout: BroadcastFilter{4151dc18 ReceiverList{4151dba0 1505 com.android.systemui/1000 remote:41506f58}}
I/Process ( 1427): Sending signal. PID: 1505 SIG: 3
I/dalvikvm( 1505): threadid=3: reacting to signal 3
I/dalvikvm( 1505): Wrote stack traces to '/data/anr/traces.txt'
I/Process ( 1427): Sending signal. PID: 1427 SIG: 3
I/dalvikvm( 1427): threadid=3: reacting to signal 3
I/dalvikvm( 1427): Wrote stack traces to '/data/anr/traces.txt'
I/Process ( 1427): Sending signal. PID: 1566 SIG: 3
I/dalvikvm( 1566): threadid=3: reacting to signal 3
I/dalvikvm( 1566): Wrote stack traces to '/data/anr/traces.txt'
D/dalvikvm( 1427): GC_CONCURRENT freed 451K, 16% free 9026K/10695K, paused 1ms+2ms
D/dalvikvm( 1427): GC_CONCURRENT freed 513K, 15% free 9155K/10695K, paused 1ms+3ms
D/dalvikvm( 1427): GC_EXPLICIT freed 70K, 15% free 9165K/10695K, paused 0ms+6ms
E/ActivityManager( 1427): ANR in com.android.systemui
E/ActivityManager( 1427): Reason: Broadcast of Intent { act=android.intent.action.TIME_TICK flg=0x40000014 (has extras) }
E/ActivityManager( 1427): Load: 0.32 / 0.28 / 0.15
E/ActivityManager( 1427): CPU usage from 5026ms to -1ms ago:
E/ActivityManager( 1427):   49% 1505/com.android.systemui: 7.9% user + 41% kernel / faults: 1 minor
E/ActivityManager( 1427):   2.1% 1347/kworker/0:2: 0% user + 2.1% kernel
E/ActivityManager( 1427):   1.5% 2156/top: 0% user + 1.5% kernel / faults: 343 minor
E/ActivityManager( 1427):   0.5% 1427/system_server: 0% user + 0.5% kernel / faults: 11 minor
E/ActivityManager( 1427):   0% 325/sync_supers: 0% user + 0% kernel
E/ActivityManager( 1427):   0.1% 2029/org.mozilla.fennec: 0.1% user + 0% kernel
E/ActivityManager( 1427): 16% TOTAL: 0.2% user + 16% kernel
E/ActivityManager( 1427): CPU usage from 316ms to 839ms later:
E/ActivityManager( 1427):   98% 1505/com.android.systemui: 0% user + 98% kernel
E/ActivityManager( 1427):     100% 1505/ndroid.systemui: 0% user + 100% kernel
E/ActivityManager( 1427):   2.9% 1347/kworker/0:2: 0% user + 2.9% kernel
E/ActivityManager( 1427):   3.8% 1427/system_server: 1.9% user + 1.9% kernel / faults: 1 minor
E/ActivityManager( 1427):     3.8% 1441/ActivityManager: 1.9% user + 1.9% kernel
E/ActivityManager( 1427):   1.4% 1380/adbd: 0% user + 1.4% kernel
E/ActivityManager( 1427):     1.4% 1382/adbd: 0% user + 1.4% kernel
E/ActivityManager( 1427): 44% TOTAL: 1.1% user + 43% kernel
W/ActivityManager( 1427): Killing ProcessRecord{4122e1a8 1505:com.android.systemui/1000}: background ANR
W/InputDispatcher( 1427): channel '414373a8 NotificationPanel (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
E/InputDispatcher( 1427): channel '414373a8 NotificationPanel (server)' ~ Channel is unrecoverably broken and will be disposed!
W/InputDispatcher( 1427): Attempted to unregister already unregistered input channel '414373a8 NotificationPanel (server)'
I/WindowManager( 1427): WIN DEATH: Window{414373a8 NotificationPanel paused=false}
I/ActivityManager( 1427): Process com.android.systemui (pid 1505) has died.
W/ActivityManager( 1427): Scheduling restart of crashed service com.android.systemui/.SystemUIService in 1250ms
W/InputDispatcher( 1427): channel '413908f0 RecentsPanel (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
E/InputDispatcher( 1427): channel '413908f0 RecentsPanel (server)' ~ Channel is unrecoverably broken and will be disposed!
I/WindowManager( 1427): WINDOW DIED Window{414373a8 NotificationPanel paused=false}
W/InputDispatcher( 1427): Attempted to unregister already unregistered input channel '413908f0 RecentsPanel (server)'
W/InputDispatcher( 1427): channel '413e0ac8 InputMethodsPanel (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
E/InputDispatcher( 1427): channel '413e0ac8 InputMethodsPanel (server)' ~ Channel is unrecoverably broken and will be disposed!
W/InputDispatcher( 1427): Attempted to unregister already unregistered input channel '413e0ac8 InputMethodsPanel (server)'
I/WindowManager( 1427): WINDOW DIED Window{413908f0 RecentsPanel paused=false}
I/WindowManager( 1427): WIN DEATH: Window{413e0ac8 InputMethodsPanel paused=false}
W/WindowManager( 1427): Failed looking up window
W/WindowManager( 1427): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@41390dd0 does not exist
W/WindowManager( 1427): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7163)
W/WindowManager( 1427): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7154)
W/WindowManager( 1427): 	at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:1545)
W/WindowManager( 1427): 	at android.os.BinderProxy.sendDeathNotice(Binder.java:417)
W/WindowManager( 1427): 	at dalvik.system.NativeStart.run(Native Method)
I/WindowManager( 1427): WIN DEATH: null
I/WindowManager( 1427): WIN DEATH: Window{41473428 StatusBar paused=false}
I/ActivityManager( 1427): Start proc com.android.systemui for restart com.android.systemui: pid=2162 uid=1000 gids={1015, 3002, 3001, 3003}
I/WindowManager( 1427): WIN DEATH: Window{413ae868 CompatModePanel paused=false}
E/InputDispatcher( 1427): Received spurious receive callback for unknown input channel.  fd=214, events=0x8
E/InputDispatcher( 1427): Received spurious receive callback for unknown input channel.  fd=218, events=0x8
I/WindowManager( 1427): WINDOW DIED Window{413e0ac8 InputMethodsPanel paused=false}
W/InputDispatcher( 1427): Attempted to unregister already unregistered input channel '413e0ac8 InputMethodsPanel (server)'
I/WindowManager( 1427): WINDOW DIED Window{413908f0 RecentsPanel paused=false}
I/WindowManager( 1427): WIN DEATH: Window{413e0ac8 InputMethodsPanel paused=false}
W/WindowManager( 1427): Failed looking up window
W/WindowManager( 1427): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@41390dd0 does not exist
W/WindowManager( 1427): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7163)
W/WindowManager( 1427): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7154)
W/WindowManager( 1427): 	at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:1545)
W/WindowManager( 1427): 	at android.os.BinderProxy.sendDeathNotice(Binder.java:417)
W/WindowManager( 1427): 	at dalvik.system.NativeStart.run(Native Method)
I/WindowManager( 1427): WIN DEATH: null
I/WindowManager( 1427): WIN DEATH: Window{41473428 StatusBar paused=false}
I/ActivityManager( 1427): Start proc com.android.systemui for restart com.android.systemui: pid=2162 uid=1000 gids={1015, 3002, 3001, 3003}
I/WindowManager( 1427): WIN DEATH: Window{413ae868 CompatModePanel paused=false}
E/InputDispatcher( 1427): Received spurious receive callback for unknown input channel.  fd=214, events=0x8
E/InputDispatcher( 1427): Received spurious receive callback for unknown input channel.  fd=218, events=0x8
I/WindowManager( 1427): WINDOW DIED Window{413e0ac8 InputMethodsPanel paused=false}
D/dalvikvm( 2162): Debugger has detached; object registry had 1 entries
W/GeckoGLController( 2029): GLController::serverSurfaceChanged(1280, 720)
D/GeckoLayerClient( 2029): Window-size changed to (1280,720)
W/GeckoGLController( 2029): GLController::resumeCompositor(1280, 720) and mCompositorCreated=true
D/SystemUIService( 2162): loading: class com.android.systemui.statusbar.tablet.TabletStatusBar
D/SystemUIService( 2162): running: com.android.systemui.statusbar.tablet.TabletStatusBar@41210b60
I/StatusBar.HeightReceiver( 2162): Resizing status bar plugged=false height=48 old=0
D/dalvikvm( 2162): GC_CONCURRENT freed 130K, 4% free 6819K/7047K, paused 1ms+2ms
D/dalvikvm( 2162): GC_FOR_ALLOC freed 22K, 3% free 7196K/7367K, paused 8ms
I/StatusBarManagerService( 1427): registerStatusBar bar=com.android.internal.statusbar.IStatusBar$Stub$Proxy@4149b508
D/dalvikvm( 2162): GC_CONCURRENT freed 51K, 3% free 7596K/7751K, paused 0ms+0ms
D/SystemUIService( 2162): loading: class com.android.systemui.power.PowerUI
D/SystemUIService( 2162): running: com.android.systemui.power.PowerUI@4131d8f0
I/StatusBar.HeightReceiver( 2162): Resizing status bar plugged=false height=48 old=48
D/WifiService( 1427): New client listening to asynchronous messages
D/dalvikvm( 1427): GC_CONCURRENT freed 762K, 17% free 8955K/10695K, paused 2ms+0ms
I/Process ( 1427): Sending signal. PID: 1427 SIG: 3
I/dalvikvm( 1427): threadid=3: reacting to signal 3
I/dalvikvm( 1427): Wrote stack traces to '/data/anr/traces.txt'
W/ActivityManager( 1427): Timeout of broadcast BroadcastRecord{41526da8 android.intent.action.TIME_TICK} - receiver=android.app.LoadedApk$ReceiverDispatcher$InnerReceiver@4128fab0, started 10038ms ago
W/ActivityManager( 1427): Receiver during timeout: BroadcastFilter{4126a758 ReceiverList{4126fee8 1427 system/1000 local:4128fab0}}
W/ActivityManager( 1427): Timeout of broadcast BroadcastRecord{41526da8 android.intent.action.TIME_TICK} - receiver=android.app.LoadedApk$ReceiverDispatcher$InnerReceiver@412e6a68, started 10048ms ago
W/ActivityManager( 1427): Receiver during timeout: BroadcastFilter{412c2b48 ReceiverList{412c6988 1427 system/1000 local:412e6a68}}
I/Process ( 1427): Sending signal. PID: 1427 SIG: 3
I/dalvikvm( 1427): threadid=3: reacting to signal 3
I/dalvikvm( 1427): Wrote stack traces to '/data/anr/traces.txt'
I/Process ( 1427): Sending signal. PID: 1566 SIG: 3
I/dalvikvm( 1566): threadid=3: reacting to signal 3
I/dalvikvm( 1566): Wrote stack traces to '/data/anr/traces.txt'
I/Watchdog_N( 1427): dumpKernelStacks
D/dalvikvm( 1427): GC_FOR_ALLOC freed 127K, 15% free 9106K/10695K, paused 47ms
I/dalvikvm-heap( 1427): Grow heap (frag case) to 9.136MB for 179768-byte allocation
D/dalvikvm( 1427): GC_FOR_ALLOC freed 1K, 15% free 9280K/10887K, paused 52ms
D/dalvikvm( 1427): GC_FOR_ALLOC freed 241K, 17% free 9126K/10887K, paused 54ms
I/dalvikvm-heap( 1427): Grow heap (frag case) to 9.113MB for 135124-byte allocation
D/dalvikvm( 1427): GC_FOR_ALLOC freed 177K, 19% free 9080K/11079K, paused 53ms
I/Process ( 1427): Sending signal. PID: 1427 SIG: 9
W/Watchdog( 1427): *** WATCHDOG KILLING SYSTEM PROCESS: com.android.server.wm.WindowManagerService
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.