Closed Bug 916362 Opened 6 years ago Closed 5 years ago

Get Marionette WebAPI tests running cleanly on debug B2G emulators

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1081529

People

(Reporter: jgriffin, Unassigned)

References

Details

Mn WebAPI tests are currently running (hidden) on debug emulators on cedar; we need to file bugs for all the failures and get them running green, so we can schedule them across all trees.

Current logs suggest that the tests fail due to B2G crashes, but this needs more investigation.
Blocks: 916363
Right now it is hitting a timeout on wait_for_homescreen. Maybe the timeout just needs to be increased when running debug (though it's already at 60 seconds...). I changed it to 5 minutes to see what happens:
https://hg.mozilla.org/projects/cedar/rev/3f89d04696f8
That got them unstuck. They all pass but then at test_outgoing.js, we get that "Could not successfully complete transport of message to Gecko, socket closed?" error followed by the rest of the tests failing due to a broken pipe:
https://tbpl.mozilla.org/php/getParsedLog.php?id=33745936&tree=Cedar&full=1

I know we had this issue in the past.. Jgriffin, do you remember if we just disabled the test that caused the original error? Or is it platform related. I guess I'll wait to see some more results to see if it is intermittent or not.
Flags: needinfo?(jgriffin)
That's a B2G crash, in the log I see:

08:07:06     INFO -  01-29 11:04:40.366    45    45 F MOZ_CRASH: Hit MOZ_CRASH() at ../../../../../gecko/js/src/../../js/src/jscntxtinlines.h:40


We only run these tests on emulators on linux64 VM's, so we haven't needed to disable them to run on other platforms.

We could disable the test on debug runs to see if it gets farther.  That's a pretty basic test, so I'm guessing if test_outgoing.js is causing this crash, many other tests will do likewise.
Flags: needinfo?(jgriffin)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081529
You need to log in before you can comment on or make changes to this bug.