Odinmonkey: disable attempts to hoist bounds checks when compiling asm.js code as it is not applicable

RESOLVED FIXED in Firefox 26

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dougc, Assigned: dougc)

Tracking

(Blocks: 1 bug)

unspecified
mozilla27
Points:
---

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed)

Details

(Whiteboard: [games])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 804839 [details] [diff] [review]
Disable attempts to hoist bounds checks when compiling asm.js code as it is not applicable

The range analysis implements hoisting of bounds checks for Ion Jit code.
However the approach is not applicable to Asm.js code and it is a waste
of time scanning for bounds checks, so this patch disables this specific
pass.

It is a small step towards defining what is needed from Range Analysis
for asm.js code.

The actual loop analysis can be useful for asm.js when it proves
limits to heap indexes as this can help avoid asm.js style heap
access bounds checks, and knowing the loop stride could help
avoid low bit masking (although the current code only handles a loop
stride of one).
Attachment #804839 - Flags: review?(luke)
Comment on attachment 804839 [details] [diff] [review]
Disable attempts to hoist bounds checks when compiling asm.js code as it is not applicable

Great
Attachment #804839 - Flags: review?(luke) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6bfcffd02d97
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(Assignee)

Comment 5

5 years ago
Comment on attachment 804839 [details] [diff] [review]
Disable attempts to hoist bounds checks when compiling asm.js code as it is not applicable

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not a bug
User impact if declined: minor performance improvement missed.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch:
Attachment #804839 - Flags: approval-mozilla-aurora?
Attachment #804839 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Whiteboard: [games]
https://hg.mozilla.org/releases/mozilla-aurora/rev/23db27f2be5b
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Assignee: general → dtc-moz
Blocks: 710398
You need to log in before you can comment on or make changes to this bug.