Closed Bug 916451 Opened 7 years ago Closed 7 years ago

browser_cmd_addon.js | html output for addon disable Test_Plug-in_1.0.0.0 - Got Test Plug-in 1.0.0.0 is already disabled., expected Test Plug-in 1.0.0.0 disabled

Categories

(DevTools :: Console, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: miker, Assigned: miker)

Details

(Whiteboard: [orange])

Attachments

(1 file)

During browser_cmd_addon.js I get the following failure:
html output for addon disable Test_Plug-in_1.0.0.0 - Got Test Plug-in 1.0.0.0 is already disabled., expected Test Plug-in 1.0.0.0 disabled

Interestingly, if I check just before receiving this message then the plugin is still enabled. If I then try to disable it via GCLI I am told that it is already disabled.

I haven't seen this on try and tests do run very quickly on my setup so maybe this is the cause.
Assignee: nobody → mratcliffe
It seems that on my laptop the Test Plugin is marked as click to activate. This means that it is half disabled.

This simple patch checks for addon.userDisabled === AddonManager.STATE_ASK_TO_ACTIVATE and acts appropriately.

Try:
https://tbpl.mozilla.org/?tree=Try&rev=31f2208dedbe
Attachment #805237 - Flags: review?(jwalker)
Comment on attachment 805237 [details] [diff] [review]
browser_cmd_addon_js-already-916451.patch

Joe is away, assigning to harth.
Attachment #805237 - Flags: review?(jwalker) → review?(fayearthur)
Whiteboard: [orange]
Attachment #805237 - Flags: review?(fayearthur) → review+
https://hg.mozilla.org/integration/fx-team/rev/b203caf12b57

Just a friendly reminder that your commit message should be summarizing what the patch is actually doing, not restating the bug title :)
Keywords: checkin-needed
Whiteboard: [orange] → [orange][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b203caf12b57
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [orange][fixed-in-fx-team] → [orange]
Target Milestone: --- → Firefox 27
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.