Intermittent TEST-UNEXPECTED-FAIL | browser_thumbnails_redirect.js | Test timed out

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: KWierso, Assigned: markh)

Tracking

({intermittent-failure})

unspecified
mozilla32
All
Windows XP
Points:
---
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed, firefox32 fixed, firefox-esr24 unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: p=13 s=it-32c-31a-30b.2 [qa-])

Attachments

(2 attachments)

Reporter

Description

6 years ago
Posted image screenshot.png
https://tbpl.mozilla.org/php/getParsedLog.php?id=27883702&tree=Mozilla-Inbound
https://secure.pub.build.mozilla.org/builddata/reports/slave_health/slave.html?name=t-xp32-ix-058

11:00:33     INFO -  --DOMWINDOW == 241 (35AD9368) [serial = 16609] [outer = 00000000] [url = chrome://global/content/mozilla.xhtml]
11:00:33     INFO -  --DOMWINDOW == 240 (13BF8550) [serial = 16600] [outer = 00000000] [url = https://example.com/browser/toolkit/components/thumbnails/test/privacy_cache_control.sjs?private]
11:00:33     INFO -  --DOMWINDOW == 239 (20A0AE60) [serial = 16603] [outer = 00000000] [url = http://mochi.test:8888/browser/toolkit/components/thumbnails/test/background_red.html]
11:00:41     INFO -  --DOMWINDOW == 238 (21513E70) [serial = 16506] [outer = 00000000] [url = about:blank]
11:00:46  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/thumbnails/test/browser_thumbnails_redirect.js | Test timed out
11:00:46     INFO -  INFO | automation.py | Launching: C:\slave\test\build\tests\bin\screenshot.exe c:\docume~1\cltbld~1.t-x\locals~1\temp\mozilla-test-fail_ovb_qw
11:00:47     INFO -  SCREENSHOT: [DATA URI STRIPPED; SEE ATTACHMENT]
11:00:48     INFO -  [Parent 3540] WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 266
11:00:48     INFO -  INFO TEST-END | chrome://mochitests/content/browser/toolkit/components/thumbnails/test/browser_thumbnails_redirect.js | finished in 30064ms
11:00:48     INFO -  TEST-INFO | checking window state
11:00:48  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/thumbnails/test/browser_thumbnails_redirect.js | uncaught exception - ReferenceError: executeSoon is not defined at chrome://mochitests/content/browser/toolkit/components/thumbnails/test/head.js:246
11:00:48     INFO -  Stack trace:
11:00:48     INFO -      JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 1155
11:00:48     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
11:00:48     INFO -  JavaScript error: chrome://mochitests/content/browser/toolkit/components/thumbnails/test/head.js, line 246: executeSoon is not defined
11:00:48     INFO -  TEST-START | chrome://mochitests/content/browser/toolkit/components/thumbnails/test/browser_thumbnails_storage.js
11:00:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/thumbnails/test/browser_thumbnails_storage.js | Console message: [JavaScript Error: "ReferenceError: executeSoon is not defined" {file: "chrome://mochitests/content/browser/toolkit/components/thumbnails/test/head.js" line: 246}]
11:00:48     INFO -  ++DOCSHELL 22EF7C08 == 93 [id = 6502]
11:00:48     INFO -  ++DOMWINDOW == 239 (23966210) [serial = 16610] [outer = 00000000]
11:00:48     INFO -  ++DOMWINDOW == 240 (371CA188) [serial = 16611] [outer = 23966210]
11:00:48     INFO -  [Parent 3540] WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 266
11:00:48     INFO -  [Parent 3540] WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 266
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Updated

6 years ago
Whiteboard: [triage]
Whiteboard: [triage]
Whiteboard: p=0
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=0 → p=13
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 130

5 years ago
All of the "background" oranges are caused by the URL expiration mechanism - the expiration timer fires between the thumbnail being written and the test waiting for the file to exist.  This is a test-only fix that simply excludes the URLs under test from being expired.

While this patch should fix all oranges in the "background" tests, I've another patch in-progress (which is not test-only) to fix all other thumbnail test oranges.
Assignee: nobody → mhammond
Attachment #8422098 - Flags: review?(adw)
Comment on attachment 8422098 [details] [diff] [review]
0001-Bug-916497-PageThumbs-no-logner-expires-thumnails-be.patch

Review of attachment 8422098 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8422098 - Flags: review?(adw) → review+
Another bug to add to the current iteration.
Flags: needinfo?(mmucci)
Whiteboard: p=13 → p=13 s=it-32c-31a-30b.2 [qa-]
https://hg.mozilla.org/mozilla-central/rev/203a4f407bcb
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Added to iteration.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mmucci)
(In reply to Mark Hammond [:markh] from comment #130)
> While this patch should fix all oranges in the "background" tests, I've
> another patch in-progress (which is not test-only) to fix all other
> thumbnail test oranges.

Was that patch going into this bug or a different one?

Also, <3!!!
Assignee

Comment 138

5 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #136)
> (In reply to Mark Hammond [:markh] from comment #130)
> > While this patch should fix all oranges in the "background" tests, I've
> > another patch in-progress (which is not test-only) to fix all other
> > thumbnail test oranges.
> 
> Was that patch going into this bug or a different one?

It will be a different one - my current understanding is those other timeouts are a real bug in the thumbnailing code, so I'll open a new bug when I nail it.

> Also, <3!!!

:)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Updated

5 years ago
Duplicate of this bug: 909611
Assignee

Updated

5 years ago
Duplicate of this bug: 909933
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.