Rename nsClientRect(List) to mozilla::dom::DOMRect(List)

RESOLVED FIXED in mozilla27

Status

()

Core
DOM
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
mozilla27
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

I think we've reached a consensus to rename ClientRect to DOMRect, but I'm still waiting for that to be officially recorded.

Anyway, I have a patch.
Created attachment 804978 [details] [diff] [review]
fix

This patch also moves the implementation from content/html/content/src to content/base/src.
Attachment #804978 - Flags: review?(Ms2ger)
Blocks: 917755
Created attachment 807035 [details] [diff] [review]
Part 2: Make DOMRectList an ArrayClass
Attachment #807035 - Flags: review?(Ms2ger)
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #0)
> I think we've reached a consensus to rename ClientRect to DOMRect, but I'm
> still waiting for that to be officially recorded.

This has happened now.
Comment on attachment 807035 [details] [diff] [review]
Part 2: Make DOMRectList an ArrayClass

bz already landed this.
Attachment #807035 - Attachment is obsolete: true
Attachment #807035 - Flags: review?(Ms2ger)
Attachment #804978 - Flags: review?(Ms2ger) → review?(khuey)
Comment on attachment 804978 [details] [diff] [review]
fix

Review of attachment 804978 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nits picked

::: content/base/src/DOMRect.cpp
@@ +58,3 @@
>  
>  
>  NS_IMETHODIMP    

while you're here can you remove the extra whitespace after NS_IMETHODIMP?

@@ +63,5 @@
>    *aLength = Length();
>    return NS_OK;
>  }
>  
>  NS_IMETHODIMP    

here too.

::: content/base/src/DOMRect.h
@@ +151,5 @@
>    nsCOMPtr<nsISupports> mParent;
>  };
>  
> +}
> +}

nit: please add // namespace foo comments here.

::: dom/webidl/moz.build
@@ +47,5 @@
>      'ChannelSplitterNode.webidl',
>      'CharacterData.webidl',
>      'ChildNode.webidl',
> +    'DOMRect.webidl',
> +    'DOMRectList.webidl',

Please keep this list in alphabetical order.
Attachment #804978 - Flags: review?(khuey) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b94cd262ef5

Comment 7

4 years ago
https://hg.mozilla.org/mozilla-central/rev/8b94cd262ef5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.