Cannot save image in WebGL filter demo by evanw

RESOLVED DUPLICATE of bug 749824

Status

()

defect
RESOLVED DUPLICATE of bug 749824
6 years ago
3 years ago

People

(Reporter: fb+mozdev, Unassigned)

Tracking

(Depends on 1 bug, {regression})

22 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130909203154

Steps to reproduce:

Visit URL and click "Save".


Actual results:

New window opens with blank image.


Expected results:

Image should be the one you were editing.
(Reporter)

Comment 1

6 years ago
Sorry, I was too quick with submitting the bug. 

So the issue may actually not be in Firefox through using non-standard APIs (haven't looked into that yet), however there are issues with similar things already reported (e. g. Bug 749824, tentatively adding as depending). The issue also exists in Nightly (2013-09-15) and there the image is not blank (white) but gray-ish (very similar to Bug 749824 attachment 786401 [details]). 

I just reported another bug for this demo but I think the issues are separate (Bug 916565).

Graphics (via Nightly)
Device ID	0x 166
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Vendor ID	0x8086
WebGL Renderer	Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
windowLayerManagerRemote	true
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Depends on: 749824
Hardware: x86 → x86_64

Comment 2

6 years ago
Reproducible on:
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (20130916030201)

This bug happen in Firefox 16.0.2 so it's a regression. Could you try finding the regression windows using mozregression?  http://mozilla.github.io/mozregression/ 

This could show us what caused this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(fb+mozdev)
OS: Mac OS X → All
Hardware: x86_64 → All

Updated

6 years ago
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
(Reporter)

Comment 3

6 years ago
I'll try to get to this next week and see what I can do (first time using mozregression). Keeping ni? for now. 


(In reply to Ioana Budnar, QA [:ioana] from comment #2)
> This bug happen in Firefox 16.0.2 so it's a regression. Could you try

I don't quite understand that. Did it work or break in 16.0.2, or which version before or after that one?
Flags: needinfo?(fb+mozdev)
(Reporter)

Comment 4

6 years ago
That did not quite work as expected …
Flags: needinfo?(ioana.budnar)
Flags: needinfo?(fb+mozdev)

Comment 5

6 years ago
(In reply to Florian Bender from comment #3)
> (In reply to Ioana Budnar, QA [:ioana] from comment #2)
> > This bug happen in Firefox 16.0.2 so it's a regression. Could you try
> 
> I don't quite understand that. Did it work or break in 16.0.2, or which
> version before or after that one?

This means it worked well in Firefox 16.0.2, so it broke somewhere after that. A bug that hasn't been in Firefox since its first versions, is called a regression. Finding the regression window means finding in which build this bug first appeared.

(In reply to Florian Bender from comment #4)
> That did not quite work as expected …
What do you mean by that?
Flags: needinfo?(ioana.budnar)

Comment 6

6 years ago
Steps to Reproduce:
1. Open URL
2. click "Save" button

Actual Results:
New tab opens with blank image.

Expected Results:
New tab opens with image.

Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9874a60b708f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130220 Firefox/22.0 ID:20130220140958
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/82747d694e7a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130220 Firefox/22.0 ID:20130220173000
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9874a60b708f&tochange=82747d694e7a

Suspected:
82747d694e7a	Jeff Gilbert — Bug 716859 - Streaming GLContext buffers (doublebuffering, etc) - r=bjacob,jrmuizel,vlad
Blocks: 716859
Version: 24 Branch → 22 Branch
(Reporter)

Comment 7

6 years ago
So I guess my task is no longer required. 

(In reply to Ioana Budnar, QA [:ioana] from comment #5)
> This means it worked well in Firefox 16.0.2, so it broke somewhere after
> that. 
OK that's what I thought, just wanted to clarify, thanks!

(In reply to Ioana Budnar, QA [:ioana] from comment #5)
> What do you mean by that?
Just needinfo? not working like I wanted it to do.
Flags: needinfo?(fb+mozdev)
Looks like this bug still reproduces.
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749824
You need to log in before you can comment on or make changes to this bug.