Annotate MozConnection with [[NoInterfaceObject]]

RESOLVED DUPLICATE of bug 952084

Status

()

RESOLVED DUPLICATE of bug 952084
5 years ago
3 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 805386 [details] [diff] [review]
Part 1: Convert MozConnection to WebIDL and unprefix it

I've unprefixed the interface because it is no longer exposed on the global object.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #805386 - Flags: review?(jonas)
(Assignee)

Comment 2

5 years ago
Created attachment 805387 [details] [diff] [review]
Part 2: Remove nsIDOMMozConnection and nsIMozNavigatorNetwork
Attachment #805387 - Flags: review?(jonas)
Added dev-doc-needed to check we didn't document MozConnection as visible, and to add a note on Fx XY for dev.
Keywords: dev-doc-needed
Comment on attachment 805387 [details] [diff] [review]
Part 2: Remove nsIDOMMozConnection and nsIMozNavigatorNetwork

Review of attachment 805387 [details] [diff] [review]:
-----------------------------------------------------------------

Over to mounir
Attachment #805387 - Flags: review?(jonas) → review?(mounir)
Comment on attachment 805386 [details] [diff] [review]
Part 1: Convert MozConnection to WebIDL and unprefix it

Review of attachment 805386 [details] [diff] [review]:
-----------------------------------------------------------------

Over to Mounir
Attachment #805386 - Flags: review?(jonas) → review?(mounir)
Comment on attachment 805386 [details] [diff] [review]
Part 1: Convert MozConnection to WebIDL and unprefix it

Review of attachment 805386 [details] [diff] [review]:
-----------------------------------------------------------------

You should not make the Connection interface a [NoInterfaceObject]. The specification is simply wrong in requesting that.
Attachment #805386 - Flags: review?(mounir)
Comment on attachment 805387 [details] [diff] [review]
Part 2: Remove nsIDOMMozConnection and nsIMozNavigatorNetwork

Please update this patch (or re-ask for a review) when you will have updated the part 1.
Attachment #805387 - Flags: review?(mounir)
(Assignee)

Comment 9

5 years ago
(In reply to Mounir Lamouri (:mounir) from comment #7)
> You should not make the Connection interface a [NoInterfaceObject]. The
> specification is simply wrong in requesting that.

Could you update the spec text?
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952084
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.