Closed Bug 916609 Opened 7 years ago Closed 7 years ago

WebRTC permission UI broken on Fx26 ("browser is not defined)

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 26
Tracking Status
firefox25 --- unaffected
firefox26 --- verified

People

(Reporter: jesup, Assigned: jib)

References

(Blocks 1 open bug)

Details

(Keywords: regression, reproducible, Whiteboard: [getusermedia])

Attachments

(1 obsolete file)

Must have been landed and uplifted recently...  Beta (24) is not affected.
E/GeckoConsole(10112): [JavaScript Error: "ReferenceError: browser is not defined" {file: "chrome://browser/content/WebrtcUI.js" line: 84}]

(on Aurora)
tracking-fennec: --- → ?
Ummmm... bug 882145 is only on central, not Aurora
This is reproducible (for me) on mozilla-central (Nightly) 09/15 only. I just installed Aurora (09/15) and am not seeing any issue.
Keywords: reproducible
We need to backout bug 882145 then if that's the confirmed regression.
Summary: WebRTC permission UI broken on 25 and 26 ("browser is not defined) → WebRTC permission UI broken on Fx26 ("browser is not defined)
Confirmed the same thing Aaron saw - reproduces on Fx26 Nightly, doesn't reproduce on Fx25 Aurora.
I can confirm also that this was working in yesterday's nightly in the build here:

ftp://ftp.mozilla.org/pub/mobile/tinderbox-builds/mozilla-central-android/1379154724/

I think Aaron is right - this looks like a regression from bug 882145.
Looks like bug 882145 updated the desktop UI but the Android fork of the UI (which apparently has no tests??) needs similar changes.

There's no reason to back anything out.  We just need to patch http://hg.mozilla.org/mozilla-central/file/9366ee039645/mobile/android/chrome/content/WebrtcUI.js#l76 with a patch like http://hg.mozilla.org/mozilla-central/diff/cf373e408a6b/browser/modules/webrtcUI.jsm

And the add a test, for goodness' sake.
Bug 882145 backed out.
Assignee: ryanvm → jib
Target Milestone: --- → Firefox 26
Attached patch This should do it (obsolete) — Splinter Review
This leaves the non-handling of .picture as it was.

And again, this needs tests; if it's not tested a Tinderbox, it's not reasonable to expect people to not break it, or to magically know when it's fixed..
Attachment #805064 - Flags: feedback?(rjesup)
Attachment #805064 - Flags: feedback?(aaron.train)
Attachment #805064 - Flags: feedback?(aaron.train) → feedback?(gpascutto)
Apparently both my android devices got "stuck" on Aurora 25a2 around or on 8/2; and apparently gUM was broken in Aurora on that rev.  (I normally run nightly, and I was also testing Beta in the run-up to release, but not Aurora.)
Attachment #805064 - Flags: feedback?(rjesup) → feedback+
https://hg.mozilla.org/mozilla-central/rev/c833bcf12ad8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
No longer need to track since the patch that regressed this was backed out.

We might need to move this patch attached here over to bug 882145.
tracking-fennec: ? → ---
Comment on attachment 805064 [details] [diff] [review]
This should do it

Thanks guys for acting so quickly on this, and bz for the quick patch!

Since this issue has been closed as fixed, I've moved the patch over to bug 882145 as jsmith suggested.

My bad for not noticing there were two webrtcUI files :-(
Attachment #805064 - Attachment is obsolete: true
Attachment #805064 - Flags: feedback?(gpascutto)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.