Closed Bug 916722 Opened 7 years ago Closed 7 years ago

B2G RIL: state of telephonyCallGroup is not correctly update after clear all the calls.

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 915638

People

(Reporter: aknow, Unassigned)

Details

[Problem]

(1). The state of telephonyCallGroup is still |connected|.
(2). because of 1. telephony.active is also wrong [1] (the correct value should be null)

[Reason]

After clear all the calls, ril_worker send "conferenceCallStateChanged" with state=null. [2]

09-16 09:54:26.383: I/Gecko(45): -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"conferenceCallStateChanged","state":null}
09-16 09:54:26.383: I/Gecko(45): TelephonyProvider: handleConferenceCallStateChanged: 0

The argument received in telephonyProvider is shown as 0, not null. In later process,
0 means connected state [3].

I think the reason is caused by ipdl [4]. The type of parameter is defined as integer. So |null| becomes |0|.

  NotifyConferenceCallStateChanged(uint16_t aCallState);

[1] http://dxr.mozilla.org/mozilla-central/source/dom/telephony/Telephony.cpp#l382
[2] http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js#l3615
[3] http://dxr.mozilla.org/mozilla-central/source/dom/telephony/gonk/TelephonyProvider.js#l220
[4] http://dxr.mozilla.org/mozilla-central/source/dom/telephony/ipc/PTelephony.ipdl#l26
Summary: B2G RIL: state of telephonyCallGroup is not correctly update after clear all the call. → B2G RIL: state of telephonyCallGroup is not correctly update after clear all the calls.
Thanks for the bug. This is the duplicate of bug 915638.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915638
You need to log in before you can comment on or make changes to this bug.