Closed Bug 916997 Opened 6 years ago Closed 6 years ago

All lines are combined to one line. when copying multiple log (Select All > Copy)

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: alice0775, Assigned: msucan)

Details

(Whiteboard: [good first verify])

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/9366ee039645
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130915030208


Steps To Reproduce:
1. Open Console
2. Right click on a log and Choose "Select All"
3. Right click on a log again and Choose "Copy"
4. Paste into <textarea> or any other editor application

Actual Results:
All lines are combined to one line:

05:56:00.039 GET http://www.mozilla.org/en-US/firefox/releases/1.0.6.html#FAQ [HTTP/1.1 200 OK 472ms]05:56:00.636 GET http://www.mozilla.org/includes/min/min.css [HTTP/1.1 200 OK 161ms]05:56:00.637 GET http://www.mozilla.org/tabzilla/media/css/tabzilla.css [HTTP/1.1 301 MOVED PERMANENTLY 303ms]05:56:00.638 GET http://www.mozilla.org/includes/min/min.js [HTTP/1.1 200 OK 485ms]05:56:00.638 GET http://www.mozilla.org/style/covehead/release-notes.css

Expected Results:
It should be divided with newline.

05:56:00.039 GET http://www.mozilla.org/en-US/firefox/releases/1.0.6.html#FAQ [HTTP/1.1 200 OK 472ms]
05:56:00.636 GET http://www.mozilla.org/includes/min/min.css [HTTP/1.1 200 OK 161ms]
05:56:00.637 GET http://www.mozilla.org/tabzilla/media/css/tabzilla.css [HTTP/1.1 301 MOVED PERMANENTLY 303ms]
05:56:00.638 GET http://www.mozilla.org/includes/min/min.js [HTTP/1.1 200 OK 485ms]
05:56:00.638 GET http://www.mozilla.org/style/covehead/release-notes.css
Thank you for the bug report!
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86_64 → All
Panos, I remember you mentioned having this problem. This patch should fix the bug. I can reproduce the problem on Linux as well, and this patch fixes it for me.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=0974a34a940d

When I did the output rewrite I specifically checked if I get all the new lines as needed. It seems subsequent work I did to fix the tests and the CSS perf issues, have caused this regression in my patches.

I'm aiming to ask for aurora approval on this patch, once landed.
Attachment #807338 - Flags: review?(past)
Comment on attachment 807338 [details] [diff] [review]
bug-916997-1-fx-team.diff

Review of attachment 807338 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #807338 - Flags: review?(past) → review+
Thanks!
Keywords: checkin-needed
Landed:
https://hg.mozilla.org/integration/fx-team/rev/f38cdc45bd50
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
we'll want this in aurora as well, once this gets over to m-c.
https://hg.mozilla.org/mozilla-central/rev/f38cdc45bd50
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Comment on attachment 807338 [details] [diff] [review]
bug-916997-1-fx-team.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #): free text selection in the web console output - bug 760876.
User impact if declined: any text selected that has multiple lines will be copied to the clipboard in a single long line.
Testing completed (on m-c, etc.): landed in fx-team, try push and landed in m-c. test included.
Risk to taking this patch (and alternatives if risky): minimal - the patch only adds new lines where needed (between messages).
String or IDL/UUID changes made by this patch: none.

Thank you!
Attachment #807338 - Flags: approval-mozilla-aurora?
Attachment #807338 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
good first verify - steps to reproduce are in the description.  Please verify against Fx26 and Fx27.
Keywords: verifyme
Whiteboard: [good first verify]
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.