Closed Bug 917254 Opened 6 years ago Closed 6 years ago

Only enable MessageEvent.ports when MessagePort is enabled

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox25 --- unaffected
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: smaug, Assigned: baku)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

No description provided.
Attached patch patchSplinter Review
Attachment #805975 - Flags: review?(bugs)
Attachment #805975 - Flags: review?(bugs) → review+
Should we get this to Aurora too?
Assignee: nobody → amarchesini
Keywords: checkin-needed
OS: Linux → All
Hardware: x86_64 → All
(In reply to comment #2)
> Should we get this to Aurora too?

Yes!
Comment on attachment 805975 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 848294
User impact if declined: MessageEvent.port can be exposed but it doesn't work.
Risk to taking this patch (and alternatives if risky): MessagePort is landed but it's disabled by pref. This MessageEvent.port is part of this new MessagePort feature but it's not disabled.
Attachment #805975 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7912be7f71db
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #805975 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Is there anything QA can do here to verify this?
Whiteboard: [qa-]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.