Closed Bug 917365 Opened 6 years ago Closed 6 years ago

"TypeError: this.connection is undefined: UI.startSimulator" when running a simulator

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(firefox26 verified, firefox27 verified, b2g-v1.2 fixed)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified
b2g-v1.2 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

Details

(Whiteboard: [needs-coverage])

Attachments

(1 file)

It doesn't break anything but prevent from displaying "connected to xxxx" and pollute the console...
Attachment #806048 - Flags: review?(paul)
Attachment #806048 - Flags: review?(paul) → review+
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26]
This seems to resolve a Firefox crash when I try to use the Simulator, so I am glad it's already fixed!
https://hg.mozilla.org/mozilla-central/rev/4ab7380d46ab
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 806048 [details] [diff] [review]
Fix an exception when starting a simulator r=paul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: can't always start the simulator
Testing completed (on m-c, etc.): fx-team, m-c
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: no
Attachment #806048 - Flags: approval-mozilla-aurora?
Attachment #806048 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed on Firefox 26b3 - 20131107161719 - on Windows 7 64bit, Ubuntu 13.04 32bit and Mac OS X 10.9.
QA Contact: ioana.budnar
Verified as fixed on the 12/04 Aurora on Windows 7 64bit, Ubuntu 13.04 32bit and Mac OS X 10.9.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.