Closed Bug 917406 Opened 11 years ago Closed 11 years ago

[e10s] Apostrophe does not work in text fields

Categories

(Toolkit :: Find Toolbar, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: playwatch, Assigned: evilpie)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Start Nighly with browser.tabs.remote set to true.
Try typing ' in Google.


Actual results:

Nighltly entered the apostrophe in the Quick find (link only) bar.


Expected results:

Nighly should have entered ' in Google text field.
I can confirm this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: fxe10s
I guess this is probably a regression from bug 666816. Maybe we should disable the / and ' shortcuts in e10s for now?
Blocks: 666816
Yeah, we have to change the code that decides whether to open the quickfind stuff. In the shorterm I can't add some hack.
Component: Untriaged → File Handling
Component: File Handling → Find Toolbar
Product: Firefox → Toolkit
Attached patch temporary fixSplinter Review
This fixes the problem, we use a CPOW for the contentDocument to check if an input element is active. The right solution would be that the content asks chrome to open the findbar at the right time, but that is part of a bigger key handling problem.
Assignee: nobody → evilpies
Status: NEW → ASSIGNED
Attachment #806185 - Flags: review?(mdeboer)
Related to Bug 910729 ?
Didn't you just write "This bug exists since Firefox3.0" in that Bug? This bug is specific to builds with e10s enabled.
Sorry, spam.
Comment on attachment 806185 [details] [diff] [review]
temporary fix

Review of attachment 806185 [details] [diff] [review]:
-----------------------------------------------------------------

Hack smell. Which bug can this bug/ I depend on/ watch to update or remove this code again?
Attachment #806185 - Flags: review?(mdeboer) → review+
I filed Bug 918376 as a followup, with the correct dependency on the e10s keyhandling bug. http://hg.mozilla.org/integration/mozilla-inbound/rev/32025f35568f
Seems like that slipped through during a merge:
http://hg.mozilla.org/mozilla-central/rev/32025f35568f
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: