Closed Bug 917440 Opened 8 years ago Closed 8 years ago

Cannot run |./mach xpcshell-test -i|

Categories

(Testing :: XPCShell Harness, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: Yoric, Assigned: chmanchester)

References

Details

Attachments

(2 files)

Attached file Console output
Today, I can't run ./mach xpcshell-test -i some_test.js. Pretty annoying.
Component: Build Config → XPCShell Harness
Product: Core → Testing
Also happens with --debugger=gdb.
Assignee: nobody → chmanchester
Comment on attachment 807772 [details] [diff] [review]
Don't attempt to read stdout of xpcshell process when running interactively;

Review of attachment 807772 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick fix!
Attachment #807772 - Flags: review?(ted) → review+
Duplicate of this bug: 918445
https://hg.mozilla.org/mozilla-central/rev/f670b486a525
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.