Closed Bug 917527 Opened 6 years ago Closed 6 years ago

crash in java.lang.IllegalStateException: get field slot from row 0 col 0 failed at android.database.CursorWindow.getString_native(Native Method)

Categories

(Firefox for Android :: General, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 27

People

(Reporter: kbrosnan, Assigned: nalexander)

References

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2202c55a-c9e7-4359-9f8f-7fd682130915.
=============================================================

java.lang.IllegalStateException: get field slot from row 0 col 0 failed
	at android.database.CursorWindow.getString_native(Native Method)
	at android.database.CursorWindow.getString(CursorWindow.java:329)
	at android.database.AbstractWindowedCursor.getString(AbstractWindowedCursor.java:49)
	at android.database.CursorWrapper.getString(CursorWrapper.java:135)
	at org.mozilla.gecko.home.FaviconsLoader.storeFaviconsInMemCache(FaviconsLoader.java:62)
	at org.mozilla.gecko.home.FaviconsLoader.access$000(FaviconsLoader.java:27)
	at org.mozilla.gecko.home.FaviconsLoader$FaviconsCursorLoader.loadCursor(FaviconsLoader.java:110)
	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:49)
	at org.mozilla.gecko.home.SimpleCursorLoader.loadInBackground(SimpleCursorLoader.java:31)
	at android.support.v4.content.AsyncTaskLoader.onLoadInBackground(AsyncTaskLoader.java:240)
	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:51)
	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground(AsyncTaskLoader.java:40)
	at android.support.v4.content.ModernAsyncTask$2.call(ModernAsyncTask.java:123)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:306)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1088)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:581)
	at java.lang.Thread.run(Thread.java:1019)

Looks to be an Android API 10 or lower crash. Are we calling an API that was added later? Will this still be an issue after the favicon rewrite?
Flags: needinfo?(ckitching)
The class referenced no longer exists as of the imminent landing of Bug 905685, and is not brought back by any subsequent favicon work currently negotiating its way through code review.

This does not necessarily mean the problem is going away - the error seems to be caused by an attempt to access the url field on a cursor that doesn't contain one.
I think the thing to do is wait for the pending rewrite to land and see if this goes away. It will probably be fixed in 26 by Bug 905685's patches.
Flags: needinfo?(ckitching)
QA Contact: ckitching
*ahem*
It seems the assignee and QA contact buttons were too close together and nobody noticed that I missed...

In any case, the code to which this bug report relates is very much nonexistent - so closing this now seems sensible. If it turns out there's an isomorphic bug in the new favicon code then let's deal with that when someone finds it.
Status: NEW → RESOLVED
Closed: 6 years ago
QA Contact: chriskitching
Resolution: --- → FIXED
Assignee: nobody → nalexander
Depends on: 905685
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.