All users were logged out of Bugzilla on October 13th, 2018

Unbreak reading of old memory report files.

RESOLVED FIXED in Firefox 26

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla27
Points:
---

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Recent changes to memory reporters (bug 911641 and bug 912165) effectively
changed the file format of memory reports.  This was inadvertent, and while the
file format does have a version number, these changes were small enough that we
can work around them without having to bump the version number.
(Assignee)

Comment 1

5 years ago
Created attachment 806410 [details] [diff] [review]
Unbreak reading of old memory report files.

This patch allows non-sentence descriptions on reports that start with certain
paths, which is enough for the file in bug 916021 to be loaded without error.
Attachment #806410 - Flags: review?(khuey)
Comment on attachment 806410 [details] [diff] [review]
Unbreak reading of old memory report files.

Review of attachment 806410 [details] [diff] [review]:
-----------------------------------------------------------------

njn++
Attachment #806410 - Flags: review?(khuey) → review+
https://hg.mozilla.org/mozilla-central/rev/95ee206d55a5
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(Assignee)

Comment 5

5 years ago
Created attachment 807029 [details] [diff] [review]
Unbreak reading of old memory report files.

Here's the patch that landed, which had one extra comment over the reviewed
version.
(Assignee)

Updated

5 years ago
Attachment #806410 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #807029 - Flags: review+
(Assignee)

Comment 6

5 years ago
Comment on attachment 807029 [details] [diff] [review]
Unbreak reading of old memory report files.

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 911641 and bug 912165.

User impact if declined: Some old memory reports files produced by about:memory (e.g. attachment 804309 [details]) will fail to load.

Testing completed (on m-c, etc.): The patch added testing.  It's been on m-c for a day without problem.

Risk to taking this patch (and alternatives if risky): Very low risk;  the patch just loosens one check done by about:memory during file loading.

String or IDL/UUID changes made by this patch: none.
Attachment #807029 - Flags: approval-mozilla-aurora?
Attachment #807029 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/c1bfb0a8c0a5
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Duplicate of this bug: 918380
You need to log in before you can comment on or make changes to this bug.