Firefox should not offer to add invalid search plugins

RESOLVED DUPLICATE of bug 351441

Status

()

RESOLVED DUPLICATE of bug 351441
5 years ago
3 years ago

People

(Reporter: jr.tt87, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0 
Build ID:20130917030214

When trying to add youtube.com to search engines Firefox displays an error and the youtube search engine does not appear in the drop down list as a result.

Steps to reproduce:
1. Navigate to http://www.youtube.com/
2. Click the icon from the left within the search toolbar
3. Click Add "Youtube Video Search"

Actual Results
Firefox displays the following -> Download Error: Nightly could not download the search plugin from: http://www.youtube.com/opensearch?locale=en_US
Firefox does not add the "youtube" search engine.

Expected Results
Firefox should add youtube search engine to the drop down list.

I tried the above in a new profile and in safe mode. Also older versions of Firefox seem to have this bug, so a regression window would be great.
(Reporter)

Updated

5 years ago
Keywords: regressionwindow-wanted

Comment 1

5 years ago
There is a extra line before xml-declaration :(

> 
> <?xml version="1.0" encoding="UTF-8"?>
> <OpenSearchDescription ...

Comment 2

5 years ago
So TE bug?
Flags: needinfo?(alice0775)

Comment 3

5 years ago
However Firefox also has a bug.
** Firefox should not display menuitem of 'Add "...."', if the xml is invalid.
Flags: needinfo?(alice0775)

Updated

5 years ago
Blocks: 335443
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
Summary: Error when trying to add youtube.com to search engines → Firefox should not display menuitem of 'Add "Invalid Search Plugin"', if the xml is invalid. (Error when trying to add youtube.com to search engines)
Version: 26 Branch → Trunk

Updated

5 years ago
Duplicate of this bug: 924108
I re-opened bug 924108 for the TE issue.

The newly-summarized issue requires that we load the plugin before offering it, which is complicated. I'm sure there are other bugs discussing this (related to the name sometimes differing between what's offered in the search dropdown and what ends up installed), but I can't seem to find it at the moment.
Summary: Firefox should not display menuitem of 'Add "Invalid Search Plugin"', if the xml is invalid. (Error when trying to add youtube.com to search engines) → Firefox should not display menuitem of 'Add "Invalid Search Plugin"', if the xml is invalid
found it!
No longer blocks: 335443
Depends on: 351441
Summary: Firefox should not display menuitem of 'Add "Invalid Search Plugin"', if the xml is invalid → Firefox should not offer to add invalid search plugins
OS: Windows 7 → All
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351441
You need to log in before you can comment on or make changes to this bug.