[Clock] Timer spinner allows for out-of-bound input

RESOLVED FIXED

Status

Firefox OS
Gaia::Clock
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jugglinmike, Assigned: gnarf)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:

1. Navigate to the "Timer" panel
2. Use the "spinner" UI element to specify a duration of 59 seconds
3. Attempt to drag the spinner upwards by one more unit

Expected: the spinner does not move

Actual: the spinner "rolls over" to an empty value
(Assignee)

Updated

5 years ago
Assignee: nobody → gnarf37
(Assignee)

Comment 1

5 years ago
Created attachment 806870 [details] [diff] [review]
patch v1

Simple range calculation error fixed.  Values can go from [0, values.length-1] not from [0, values.length]
Attachment #806870 - Flags: review?(mike)
(Reporter)

Comment 2

5 years ago
Comment on attachment 806870 [details] [diff] [review]
patch v1

Review of attachment 806870 [details] [diff] [review]:
-----------------------------------------------------------------

Nicely done, Corey.
Attachment #806870 - Flags: review?(mike) → review+
(Assignee)

Comment 3

5 years ago
master: https://github.com/mozilla-b2g/gaia/commit/8a4a02484fadf275a43c112153b88eb7b1538862
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
Requesting "koi+" because invalid input should not be allowed.
blocking-b2g: --- → koi?
triage: koi+, low-risk
blocking-b2g: koi? → koi+
Uplifted 8a4a02484fadf275a43c112153b88eb7b1538862 to:
v1.2: e679bea2a5725a942353b970dace18c30129d6ca
status-b2g-v1.2: --- → fixed
Verified on Buri 1.2 mozilla RIL.  Attempting to scroll the timer rollers past their limit will cause the rollers to snap back to the maximum value (23 for hour, 59 for minute and second) once they're released.

Build ID: 20130925004005
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/fb764e648a8f
Gaia: b0e4a1333bb7bf0a749a384ba99e4f03f111e39a
Platform Version: 26.0a2
status-b2g-v1.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.