Regression: Search not conducted with pasted query; matches results when typed manually

VERIFIED DUPLICATE of bug 917350

Status

()

defect
VERIFIED DUPLICATE of bug 917350
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({regression, reproducible})

27 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26 affected, firefox27 affected, fennec26+)

Details

(Reporter)

Description

6 years ago
Currently if you paste a string query, no matched results are found or no transaction takes place. If you type the same string query manually, you'll get results as expected

Steps to Reproduce

i) Visit Google
ii) Tap the address bar, cut 'google' from the URL, erase everything else
iii) Paste the string, 'google'

Expected: Results, switch to tab at least
Actual: Only search suggestions

--
LG Nexus 4 (Android 4.3)
Samsung Galaxy S4 (Android 4.3)
(Reporter)

Comment 1

6 years ago
Also reproducible with a long-tap on the address-bar of an open-page, copy address. Paste the address into the URL bar and see no results. Would have expected to see my tab open to switch to tab to it.
Regression window-wanted:

1.mc:
not affected build: 20-08-2013
affected build: 21-08-2013  
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb025b6949e8&tochange=d136c8999d96

2. inbound:
not affected build: 1377079931 
affected build : 1377087074 
-pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b7fbfd4de77c&tochange=ab6bc4d9e4c0
(Reporter)

Comment 3

6 years ago
300 change-sets in that inbound push-log but whole mishmash of new-about-home front-end work from Sriram/Lucas/Margaret.
Can we get a regression range from fx-team? If not, I can help investigate this.
Yes, the builds exist at http://ftp.mozilla.org/pub/mobile/tinderbox-builds/fx-team-android/

Teodora would you look at the fx-team builds?
Flags: needinfo?(teodora.vermesan)
Regressionwindow-wanted:

not affected build :1377068233
affected build: 1377087076  
pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=072341c2c66f&tochange=3d355303f4da
Flags: needinfo?(teodora.vermesan)
(Reporter)

Comment 7

6 years ago
Same situation as above with the inbound merge to m-c to fx-team
I'm sorry, I should have looked more closely. It looks like this is from the first big fig->m-c merge, which is unfortunate. This regression is probably just part of our big browser toolbar editing mode changes. I can look into it.
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 26+
My patch in bug 917350 fixes this issue if you paste while you're already in editing mode.

However, even with that patch, we still don't show filtered results if you select the "Paste" context menu item on the urlbar while not in editing mode, so I'll work on fixing that issue here.
Lucas, is this related to bug 917350? Will the patch you're working on for that bug address this one?
Flags: needinfo?(lucasr.at.mozilla)
(Assignee)

Comment 11

6 years ago
(In reply to :Margaret Leibovic from comment #10)
> Lucas, is this related to bug 917350? Will the patch you're working on for
> that bug address this one?

Yep, my patches in bug 917350 fix this bug too.
Assignee: margaret.leibovic → lucasr.at.mozilla
Flags: needinfo?(lucasr.at.mozilla)
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917350
(Reporter)

Comment 13

6 years ago
Confirmed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.