click to play ignores my preferences, breaks IETab

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tenisthenewnine, Unassigned)

Tracking

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Hi all,

Recently a change happened which is a bit annoying - even when going to about:config and disabling click to play completely I still get prompted, and some of my custom plugins don't work (such as Lansweeper and IEtab).

How can I force all plugins to run by default? I've tried making sure in the plugins section on about:addons I've got everything enabled.

Thanks

Updated

5 years ago
Blocks: 738698
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

5 years ago
When you say "going to about:config and disabling click to play completely" what do you mean? The old pref "plugins.click_to_play" has almost no effect nowadays. However in the addon manager you should be able to set particular plugins to "always activate".

Could you provide more specific steps here? This bug is light on details.
Flags: needinfo?(tenisthenewnine)
(In reply to Grant from comment #0)
> Recently a change happened which is a bit annoying - even when going to
> about:config and disabling click to play completely I still get prompted,
> and some of my custom plugins don't work (such as Lansweeper and IEtab).

If extensions depend on specific plugins, they should activate the instances they need.
Have you reported the issues to the developers?
(Reporter)

Comment 3

5 years ago
I haven't reported it, because it was broken through CTP and not through them.

Is there a way to turn off CTP 100% completely
Flags: needinfo?(tenisthenewnine)

Comment 4

5 years ago
In the addons manager you can configure which plugins you want to run by default. Extension developers who provide rely on plugins should set the correct defaults in their default preferences.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.