Set.js contains lots of .call()

RESOLVED DUPLICATE of bug 987243

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 987243
4 years ago
2 years ago

People

(Reporter: jorendorff, Assigned: jorendorff)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
I think all these need to be replaced with callFunction.
(Assignee)

Comment 1

4 years ago
Lest I get pegged with the review I'm taking this.
Assignee: general → jorendorff
(Assignee)

Comment 2

4 years ago
Created attachment 807714 [details] [diff] [review]
v1

This patch changes the error message when you do something silly like:

js> var obj = new Date;
js> obj.forEach = Map.prototype.forEach;
js> obj.forEach(_ => _)
typein:3:0 TypeError: entries method called on incompatible Date

It used to say "unknown type object".
Attachment #807714 - Flags: review?(till)
Comment on attachment 807714 [details] [diff] [review]
v1

Review of attachment 807714 [details] [diff] [review]:
-----------------------------------------------------------------

There's nothing not to love about this.
Attachment #807714 - Flags: review?(till) → review+
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987243
You need to log in before you can comment on or make changes to this bug.