--enable-tests build fails with gcc_hidden.h on libc++: '_ZNSt3__112basic_stringIcNS_11char_traitsIcEENS_9allocatorIcEEED1Ev' et al. are hidden

RESOLVED FIXED in Firefox 26

Status

Firefox Build System
General
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: Jan Beich, Assigned: Jan Beich)

Tracking

Trunk
mozilla27
All
FreeBSD

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
FreeBSD 10 no longer ships with libstdc++-4.2 on tier1 platforms[1]. This exposes breakage with libc++ and pragma visibility (via gcc_hidden.h) in media/webrtc/trunk/testing/gtest_gtest/gtest-test-part.o while the build stops a bit later, in signaling/test at link time.

[1] http://svnweb.freebsd.org/changeset/base/255321
(Assignee)

Comment 1

5 years ago
Created attachment 807034 [details] [diff] [review]
expose <iosfwd>
Attachment #807034 - Flags: review?(mh+mozilla)
Attachment #807034 - Flags: review?(mh+mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c1df3f2ca71
Assignee: nobody → jbeich
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3c1df3f2ca71
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Jan, i think you want this backported to aurora since it's also affected..
(Assignee)

Comment 5

5 years ago
Comment on attachment 807034 [details] [diff] [review]
expose <iosfwd>

[Approval Request Comment]
Bug caused by: exposed on FreeBSD by bug 807492, existed before
User impact if declined: broken build on libc++ platforms with gcc_hidden.h (FreeBSD and maybe Linux, OS X)
Testing completed: landed on m-c
Risk to taking this patch: none
String or IDL/UUID changes made by this patch:
Attachment #807034 - Flags: approval-mozilla-aurora?
Attachment #807034 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/afd59cdec0d1
status-firefox26: --- → fixed
status-firefox27: --- → fixed

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.