Debug button fails the first time when the app isn't installed yet on the simulator

VERIFIED FIXED in Firefox 26

Status

()

Firefox
Developer Tools: WebIDE
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

unspecified
Firefox 27
Points:
---

Firefox Tracking Flags

(firefox26 verified, firefox27 verified)

Details

(Whiteboard: [needs-coverage])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We are facing a race condition when starting debugging an app on the simulator, only when the app isn't installed yet. In 99% cases, you will see an alert popup saying appNotFound.
(Assignee)

Comment 1

4 years ago
Created attachment 807299 [details] [diff] [review]
Fix launch and getAppActor races when debugging non-already-installed simulator apps

We had two races:
- the launch request replies immediatly, so that the app may not be opened yet,
so that if we call getAppActor, its iframe doesn't exists yet.
- after install request, if we call launch immediatly, it may also race
as the homescreen may not have registered the app yet.
(Assignee)

Updated

4 years ago
Attachment #807299 - Flags: review?(paul)
(Assignee)

Updated

4 years ago
Assignee: nobody → poirot.alex

Updated

4 years ago
Whiteboard: [needed-in-aurora-26]

Updated

4 years ago
Blocks: 912913

Comment 2

4 years ago
Comment on attachment 807299 [details] [diff] [review]
Fix launch and getAppActor races when debugging non-already-installed simulator apps

On a side note, We can still click on "debug" when the toolbox is already open. We might want to just raise the toolbox when we click on debug the second time.
Attachment #807299 - Flags: review?(paul) → review+

Comment 3

4 years ago
(In reply to Paul Rouget [:paul] from comment #2)
> Comment on attachment 807299 [details] [diff] [review]
> Fix launch and getAppActor races when debugging non-already-installed
> simulator apps
> 
> On a side note, We can still click on "debug" when the toolbox is already
> open. We might want to just raise the toolbox when we click on debug the
> second time.

bug 918695

Comment 4

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/4ea055ede551

Comment 5

4 years ago
Comment on attachment 807299 [details] [diff] [review]
Fix launch and getAppActor races when debugging non-already-installed simulator apps

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: can't easily debug app running in the simulator
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #807299 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/4ea055ede551
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27

Updated

4 years ago
Priority: -- → P1
Attachment #807299 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
Whiteboard: [needed-in-aurora-26] → [land-in-aurora-26]

Comment 7

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/bef0f42eeada
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Whiteboard: [land-in-aurora-26]

Updated

4 years ago
Keywords: verifyme
Verified as fixed on FF 26.06
Build Id: 20131118212339

Environment used:
Windows 7 x64
Mac Os X 10.7.5
Ubuntu 12.10 x32
status-firefox26: fixed → verified
I wasn't able to reproduce this issue with the Nightly from 2013-09-19 on Win 7 64-bit, with Firefox OS 1.3 simulator (I've also tried with 1.2).

I've tried with these 3 hosted apps:

http://people.mozilla.org/~cmills/app-template/manifest.webapp
http://bugmotodo.org/manifest.webapp
http://paulrouget.com/hn-fxos/manifest.webapp

I can't see the alert popup saying appNotFound, after I start the simulator, I add a hosted app and press "Debug" (without previously clicking on "Update").

Does anyone have any thoughts/suggestions? Thanks!
Flags: needinfo?(poirot.alex)
(Assignee)

Comment 10

4 years ago
I don't know why we don't see the alert dialog on that nightly,
but the toolbox doesn't appear, that's the result of the regression we fixed in this patch.
We this patch the toolbox should appear no matter if the app was already installed/running or not.
The alert dialog may have been remove by some other changeset that happened in the same time frame.
I remember that we fixed various regression at that point.
Flags: needinfo?(poirot.alex)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

Verified as fixed on Firefox 27 Beta 5 (Build ID: 20140109165205).
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
Keywords: verifyme
Whiteboard: [needs-coverage]
You need to log in before you can comment on or make changes to this bug.