The default bug view has changed. See this FAQ.

Print dialog box appears under other open windows for Mail & News

RESOLVED FIXED in seamonkey2.24

Status

SeaMonkey
MailNews: General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gah6, Assigned: rsx11m)

Tracking

({regression})

Trunk
seamonkey2.24
regression

SeaMonkey Tracking Flags

(seamonkey2.21 wontfix, seamonkey2.22 fixed, seamonkey2.23 fixed, seamonkey2.24 fixed)

Details

Attachments

(1 attachment)

1003 bytes, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 SeaMonkey/2.21 (Beta/Release)
Build ID: 20130908220716

Steps to reproduce:

Choose any email in any folder.  Click the print button, right click and choose print, or choose File -> Print


Actual results:

When I print an email, the print dialog, which shows the printer to be used, pops up briefly and then disappears below all the other open windows.  I have to minimize all the windows to find that dialog and click OK to get it to print. 


Expected results:

In the past, the print dialog appeared on top of all open windows and stayed there.

NOTE:  This bug is identical to this one:

https://bugzilla.mozilla.org/show_bug.cgi?id=893548

That bug was specific to TB, but the behavior is the same in SM.  Hopefully the same fix can be applied, and soon, as I've had multiple questions on this since 2.21 autoupdated this morning.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 893548
(Assignee)

Comment 1

4 years ago
Yes, SeaMonkey has a similar function PrintEnginePrintInternal() in its implementation of mailWindowOverlay.js, thus the same fix should work here as well. I'll test it with the last argument of that function removed and will post a patch later if it works out of the box.
Assignee: nobody → rsx11m.pub
Status: NEW → ASSIGNED
status-seamonkey2.21: --- → affected
(Assignee)

Updated

4 years ago
status-seamonkey2.22: --- → affected
status-seamonkey2.23: --- → affected
status-seamonkey2.24: --- → affected
Component: General → MailNews: General
Summary: Print dialog box appears under other open windows → Print dialog box appears under other open windows for Mail & News
Version: SeaMonkey 2.21 Branch → Trunk
(Assignee)

Updated

4 years ago
status-seamonkey2.24: affected → ---
Duplicate of this bug: 918521
(Assignee)

Comment 3

4 years ago
Hmm, bugzilla is playing games with me and removed the tracking flag when marking the duplicate...

Reproduced on 2.21 and 2.24, thus I assume that aurora and beta channels are affected as well. I'm unable to reproduce this on Linux with KDE4 on current trunk, so this may be a Windows-only effect (where in general the problem as such should be present on all platforms, just may manifest itself differently).
status-seamonkey2.24: --- → affected
(Assignee)

Comment 4

4 years ago
Created attachment 807520 [details] [diff] [review]
Simple fix

This is a straight port from bug 893548 attachment 792931 [details] [diff] [review] and fixes the issue for me on both SM 2.21 and 2.24 on Windows. I've also tested on Linux without seeing any effect (i.e., the problem didn't show up there in the first place, but the patch doesn't hurt either).
status-seamonkey2.24: affected → ---
Attachment #807520 - Flags: review?(neil)

Comment 5

4 years ago
Comment on attachment 807520 [details] [diff] [review]
Simple fix

Given that the print dialog parents itself to the (hidden) print engine window, we probably want the print progress it parent itself to the same window.
Attachment #807520 - Flags: review?(neil) → review+
(Assignee)

Comment 6

4 years ago
Neil, I don't really know what you mean. The progress bar for printing shows up fine in the foreground, and I don't see any reference to it in mailWindowOverlay.js (and, quite frankly - I have no clue what I'm doing here = just ported the TB patch without any idea how it works).

So, unless I've missed some other usability issue (in which case please provide a pointer to it), can we check this in as is to fix the immediate problem and get it on the branches? If there are any other improvements to the printing dialogs, those can probably be handled in another patch targeting trunk.
Flags: needinfo?(neil)

Comment 7

4 years ago
Sorry, that was just a comment in case I ever needed to remind myself of why I granted the review.
Flags: needinfo?(neil)
(Assignee)

Comment 8

4 years ago
Ok, thanks; that wasn't clear to me and I got slightly confused. :-)
Push for comm-central, please.
status-seamonkey2.24: --- → affected
Keywords: checkin-needed, regression
(Assignee)

Comment 9

4 years ago
Comment on attachment 807520 [details] [diff] [review]
Simple fix

[Approval Request Comment]
Regression caused by (bug #): unknown, but wasn't present in 2.20
User impact if declined: being puzzled where to find the print dialog
Testing completed (on m-c, etc.): patch tested on 2.21, 2.22, and 2.24 builds
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none

I don't know if there will be a 2.21.1, but in case it does, this should land on comm-release as well.
status-seamonkey2.24: affected → ---
Attachment #807520 - Flags: approval-comm-release?
Attachment #807520 - Flags: approval-comm-beta?
Attachment #807520 - Flags: approval-comm-aurora?
(Assignee)

Comment 10

4 years ago
(I'm giving up on the status-seamonkey2.24 flag.)

Comment 11

4 years ago
Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/1a95c72ddfa0
Keywords: checkin-needed
Whiteboard: [leave open for aurora/beta/release]
Target Milestone: --- → seamonkey2.24

Updated

4 years ago
Duplicate of this bug: 920001
(Assignee)

Updated

4 years ago
Duplicate of this bug: 922435

Updated

4 years ago
Attachment #807520 - Flags: approval-comm-beta?
Attachment #807520 - Flags: approval-comm-beta+
Attachment #807520 - Flags: approval-comm-aurora?
Attachment #807520 - Flags: approval-comm-aurora+
(Assignee)

Updated

4 years ago
tracking-seamonkey2.21: --- → ?
Keywords: checkin-needed
Whiteboard: [leave open for aurora/beta/release] → [c-n: comm-aurora/comm-beta][leave open for release]
https://hg.mozilla.org/releases/comm-aurora/rev/1494e3b76ac7
https://hg.mozilla.org/releases/comm-beta/rev/018ae8d19d04
status-seamonkey2.22: affected → fixed
status-seamonkey2.23: affected → fixed
status-seamonkey2.24: --- → fixed
Keywords: checkin-needed
Whiteboard: [c-n: comm-aurora/comm-beta][leave open for release] → [leave open for release]
(Assignee)

Comment 15

4 years ago
Comment on attachment 807520 [details] [diff] [review]
Simple fix

Next stop will be SM 2.22, thus I'm canceling the comm-release request.
Attachment #807520 - Flags: approval-comm-release?
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.21: affected → wontfix
tracking-seamonkey2.21: ? → ---
Resolution: --- → FIXED
Whiteboard: [leave open for release]
You need to log in before you can comment on or make changes to this bug.