Add a reveal password toggle to input type="password"

RESOLVED DUPLICATE of bug 502258

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 502258
4 years ago
3 years ago

People

(Reporter: miker, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
firefox-backlog -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Created attachment 807473 [details]
Password reveal button

On windows 8 password fields have an eye on the right which can be clicked to reveal a password.

I saw an impressive addon:
https://addons.mozilla.org/firefox/addon/password-knight/

There are four field states:
1. Default is a normal password field with an eye on the right-hand side.
2. If the eye is clicked then the password is displayed in plain text.
3. When a password field is insecure it has a warning icon instead of an eye.
4. Clicking the warning icon displays a dialog explaining why the dialog is insecure.

Of course, the warning icon could be irritating so it should only be displayed when absolutely necessary.

Maybe this is some awesome that we could consider adding to Firefox?
Created attachment 807474 [details]
Password reveal icon clicked
Created attachment 807476 [details]
Warning icon clicked
Windows 8 natively doesn't do the warning stuff, it just lets you toggle.  This is a fantastic feature when you're typing some absurdly long phrase (*cough* LDAP *cough*), _especially_ on a touchscreen keyboard.  An increasing number of Android apps have this as a feature, it'd be a huge usability win.  If users struggle with entering long passwords, they'll go back to using shorter passwords.

Given the password-based encryption in Firefox Accounts I think the lack of this feature is a potential failure state.  To that end, nominating for firefox-backlog.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog-

Comment 5

4 years ago
This bug was not included in the Firefox Desktop backlog at present because it requires a more general discussion, at the platform level, before we can consider it actionable.
Paolo, can you clarify what the conversation is you think we should have, and where we need to have it?  I'd be happy to drive it.

Comment 7

4 years ago
(In reply to Mike Connor [:mconnor] from comment #6)
> Paolo, can you clarify what the conversation is you think we should have,
> and where we need to have it?  I'd be happy to drive it.

We need to understand the exact problem we're trying to solve and the trade-offs between the proposed design and possible confusion deriving by the new options. We probably need consistency or appropriate differences across platforms, but I'm not an UX expert so I don't know which would apply here.

Our go-to place for this type of usability improvement discussions used to be mozilla.dev.usability, but I haven't seen much activity there lately, so I'd suggest either mozilla.dev.platform or firefox-dev.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502258
You need to log in before you can comment on or make changes to this bug.