Running mutt tests under FF Metro should not fail

RESOLVED WONTFIX

Status

Testing Graveyard
Mozmill
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Andrei Eftimie, Assigned: Andrei Eftimie)

Tracking

Details

(Assignee)

Description

5 years ago
We have several failures while running mutt tests under Metro.

The following tests fail:
> testElementsLib/testMozElementWindow.js
> testElementsLib/testRadioButtons.js
> testElementsLib/testMozElementWindow.js
> testElementsLib/testMozElement.js
> testElementsLib/testMenuList.js
> testController/testScreenshot.js
> testController/testDndContentChrome.js
> testController/testContextMenu.js

Some of them might be real failures, and we may be able to fix them.

Others like testContextMenu and testMenuList make use of UI features which are not available in Metro at all, or need special handling.

ATM mutt test need to be run directly with mozmill.

We also need to enable mutt to run direclty with metro, like:
> mutt testjs -b %path% --app=metrofirefox
This is handled in bug 895841

I'll look into each failure, see if we can fix it.
For those that can not be run under metro we might need to skip them (find a good way to do that).
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Most of the existing tests are not targeted to be run with Firefox Metro. So something else we need is the application support for manifests. Or we might want to check how this has been done for b2g and Marionette. There you can specify something like 'b2g=true'. So we could have 'metro=true'.
(Assignee)

Comment 2

5 years ago
The question is, should mutt test rely on any UI at all?
Most of them test low level API's that don't depend on specific UI features.

We could argue that all of the mutt tests should follow this cree.
The problem is that some functionality might be hard or impossible to test without specific UI features.

But (at least in theory) we should be able to run all mutt tests under metro as well
It will only work for content but not for chrome pages. That's why I tried to avoid to have tests in the mutt suite which rely on Firefox specific chrome elements.
(Assignee)

Comment 4

4 years ago
This is not valid anymore.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
OS: Windows 8 Metro → Windows 8.1
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.