Can't remove breakpoints from prettyprinted scripts

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
5 years ago
6 months ago

People

(Reporter: rcampbell, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:

0. Load a page with some minified JS
1. Prettify a minified file.
2. Add a breakpoint
3. Reload.
4. Remove Breakpoint
5. Reload.

Expected: Breakpoint is not present after reload.

Actual: Sometimes the breakpoint sticks around.

nightly.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
I tried the STR from comment 0 on Facebook a lot of times, and I am able to remove breakpoints reliably ...
Priority: -- → P3
Summary: Unable to remove breakpoints on reloaded Pretty Printed JS files → [prettify] Unable to remove breakpoints on reloaded Pretty Printed JS files
That's not reproducible for me on Nigthly (2014-07-27). My steps:

1. Opened the devtools debugger on jquery.com
2. Enabled pretty-printing
3. Seleted main.js
4. Set a breakpoint on line 4 ("var c,")
5. Reloaded the page
6. Clicked the breakpoint column at line 4 to remove the breakpoint again

Is that still reproducible by you? And if so, what's the test case for this?

Sebastian
Could this be related to bug 952612?
Blocks: 1070862
Flags: needinfo?(rcampbell)
Summary: [prettify] Unable to remove breakpoints on reloaded Pretty Printed JS files → Can't remove breakpoints from prettyprinted scripts
Flags: needinfo?(rcampbell)

Comment 4

2 years ago
Is this also an issue in the current version of Nightly?

Version: 55.0a1 (2017-06-06) (64-Bit)
I tested this again using the new debugger UI in Firefox 56.0a1 (2017-06-19) and I still cannot reproduce the bug.
Therefore, I finally close this report now. If it reoccurs, let's open a new report.

Sebastian
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 6

a year ago
Today this also makes my life hard. Breakpoint is not going away when debugging ajax related code. I disable it with all given ways but it keeps coming back on reload.Even it says "no breakpoints".

Comment 7

a year ago
Ok. I can disable it but not remove.It is of course impossible reproduce how it started. But it(moment it appeared) had very much to do with ajax async operation and alert box. I just wish it would go away. I renamed the js file, reloaded. It was gone then restarted firefox and renamed file back to original on server and reloaded and breakpoint was there again. Maybe I offer it an empty file with same name.....

Comment 8

a year ago
OK That works! Here is how. Give it an empty file with same name . At first it still shows stubborn breakpoint even for empty file. Now remove breakpoint and reload and it is gone.
Fill your file again. No more breakpoint. But there was a hint: even when it was empty first time the stuck breakpoint was there.

Comment 9

8 months ago
This is still a bug, confirmed in 60.0b12 (64-bit). I cannot get rid of a single breakpoint I set while in pretty-print view, and no breakpoints show in the breakpoints field. I can set and unset the lines that are flagged, resume, and get out of the loop, but same case on next reload. Where are these breakpoints being cached?

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.