Closed Bug 918894 Opened 6 years ago Closed 6 years ago

[B2G][Buri][Settings] Keyboard menu name in Settings app appears to be displayed in Turkish as "Klavye" when the device language is set to English.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 916917

People

(Reporter: jzimbrick, Assigned: rudyl)

Details

(Keywords: regression, Whiteboard: burirun1)

Description:
The name of the keyboard menu in the settings app appears to be rendered in Turkish when the device language is set to English.

Repro Steps:
1. Update Buri device to 1.2 moz build 20130920004004.
2. Set language to English during the FTU.
3. Open the Settings app.
4. Scroll down to the keyboard menu.
5. Observe that the title of the keyboard menu appears to be rendered in Turkish as "Klavye", though the device language is set to English.

Actual:
Keyboard menu name in settings is displayed in Turkish.

Expected:
Keyboard menu name in settings is displayed in the currently selected language.

Environmental Variables
Build ID: 20130920004004
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/46b216260c1d
Gaia: 88e73da95f1c550f2fb0572480a40c989d37c997
Platform Version: 26.0a2
Base Image: 20130912

Notes:
Repro frequency: 100%

Probably related to bug 916917.
No longer blocks: b2g-central-dogfood
QA Contact: nkot
Regression range:
Build ID: 20130918004001 - Does NOT Reproduce
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/0322470077b7
Gaia: 9b1b262e8fde58be453fb05ed91c0e93ab86d394
Platform Version: 26.0a2

Build ID: 20130919004001 - Reproduces
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/2e560c5ce351
Gaia: c932c482c6944fa32724ce7af9e5423c4c2bcccd
Platform Version: 26.0a2
Whiteboard: burirun1
It is still reproduce in today's buri pvt master build.
It might appear in different languages when you switch to another language and switch back.
Rudy, could you reassign?
Assignee: nobody → rlu
blocking-b2g: koi? → koi+
Flags: needinfo?(rlu)
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(rlu)
Resolution: --- → DUPLICATE
Duplicate of bug: 916917
blocking-b2g: koi+ → ---
You need to log in before you can comment on or make changes to this bug.