JSSourceHandler called with wrong line length parameter

VERIFIED DUPLICATE of bug 79485

Status

()

VERIFIED DUPLICATE of bug 79485
18 years ago
17 years ago

People

(Reporter: olaf.meincke, Assigned: rogerl)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The call to SendSourceToJSDebugger gets a wrong value for the length. This 
problem has already been fixed in bug #79485, but turned up again in the 
current CVS sources (from Jul 21 2001).

Again, the problem seems to be in function GetChar in jsscan.c. Moving the 
lines 328-331:

if (ts->listener) {
  ts->listener(ts->filename, ts->lineno, ts->userbuf.ptr, len,
               &ts->listenerTSData, ts->listenerData);
}

to line 363, i.e. just behind 

if (len >= JS_LINE_LIMIT)
  len = JS_LINE_LIMIT - 1;
 
the length in the call to SendSourceToJSDebugger is correct. This is the 
position where you can find these lines in the patch I mentioned above.
The status on bug 79485 says Assigned with a target of 0.9.3. Tracking two bugs
that have the same goal makes no sense. This should really be a comment in that
bug. Marking dupe.

*** This bug has been marked as a duplicate of 79485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Bug 79485 "JSSourceHandler called with wrong line length parameter"
is still assigned, and the patch to jsscan.c has not yet been checked in.
Verifying as Duplicate -

Olaf, you are now cc'ed on bug 79485 so you can follow its progress.
Thank you for reminding us of this bug!  
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.