Closed Bug 919155 Opened 6 years ago Closed 6 years ago

After editing a source, it takes multiple page refreshes for the text contents to get updated in the debugger

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox26 verified, firefox27 verified)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified

People

(Reporter: vporof, Assigned: vporof)

Details

(Keywords: verifyme)

Attachments

(2 files)

More precisely, it takes 2 refreshes.

This is because we're clearing the cache too late, on the target's "navigate" notification. However, newScript events can be fired in between "will-navigate" and "navigate" as well, in which case it takes another refresh to actually refetch the source's text.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #808155 - Flags: review?(rcampbell)
Priority: -- → P1
Comment on attachment 808155 [details] [diff] [review]
dbg-discard-sources.patch

Review of attachment 808155 [details] [diff] [review]:
-----------------------------------------------------------------

you bet.
Attachment #808155 - Flags: review?(rcampbell) → review+
Comment on attachment 808155 [details] [diff] [review]
dbg-discard-sources.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Caching sources too long while reloading.
User impact if declined: Developers using the debugger will usually need to reload their app twice before being able to inspect the new sources.
Testing completed (on m-c, etc.): locally, fx-team
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #808155 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e4428c901e4c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Attachment #808155 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This has conflicts due to bug 800857 not being on Aurora. Please attach a branch-specific patch or request approval for that as well.
Flags: needinfo?(vporof)
Will do.
Flags: needinfo?(vporof)
Keywords: verifyme
Verified as fixed on FF 26.0b2:

Build Id: 20131104182142
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

OS:Windows 7 x64
Ubuntu:10.8 x32
Mac Os X: 10.8.4
Verified as fixed on FF 27.0b2:

Build Id: 20131105004004
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

OS:
Windows 7 x64
Ubuntu:12.04 x32
Mac Os X: 10.8.4
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.