[B2G][Helix][gallery][yangshiqi]It has some low posibiities that after taking picture or deleting picture,gallery stop in the flashing page that can not display picture.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Gallery
P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:[B2G][Helix][gallery][yangshiqi]It has some low posibiities that after taking picture or deleting picture,gallery stop in the flashing page that can not display picture. 
                         1.taking a picture/deleting a picture 
			 2.enter into gallery to check the picture
【Expect Result*】:The pictrue has been displayed/the picture has been deleted
【Real Result*】:the gallery is in flashing status and don not display thumbnial/the gallery is in flashing status and thumbnail do not disappear,but it will be noting but a grey page when you press it. 
【Test Count*】:20
【Found Count*】:2
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Updated

4 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Flags: needinfo?(wchang)
Priority: -- → P2

Updated

4 years ago
Severity: blocker → normal
blocking-b2g: hd? → ---
Flags: needinfo?(wchang)
Keywords: qawanted

Comment 1

4 years ago
Hi, all,

I cannot reproduce this case on latest Mozilla build and Commercial build.
Following is my test steps and build.

* Test Step:
 1. Prepare 500 pictures on the SD card and each picture is less than 200 KB
 2. Launching the Gallery app and wait for loading
 3. Tap the camera icon of lower left corner to launch the camera
 4. Take a picture
 5. Tap the preview image of upper right corner
 6. Tap the Trash can icon of lower right corner to delete photo
 7. While FxOS goes back to the camera app, tapping "田" icon of lower right corner to go back to the Gallery app
 8. Repeat step 3 ~ step 7


* Test Build:
 + Commercial build:
  - Gaia:     4afe209fb0d5c0e03d655a4e900ab8f13ca8fb4a
  - Gecko:   
  - BuildID   20131016181557
  - Version   18.0

 + Mozilla build:
  - Gaia:     c829a2042594b6c3a4899ee27979799a0f301534
  - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f7c657f6d019
  - BuildID   20131015042201
  - Version   18.0

The reproduce step is rough. Could you please provide detailed information and test environment?
Also, if possible, please provide the logs. These information can help us narrow down the test scope.
Many thanks!


Please reopen it if bug still happen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.