.gif images don't play on m.imgur.com after swiping to the next image

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Demetrius Schwab, Unassigned)

Tracking

({reproducible})

27 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:27.0) Gecko/27.0 Firefox/27.0 (Nightly/Aurora)
Build ID: 20130922030201

Steps to reproduce:

Navigated to m.imgur.com/r/gifs let first file load then swipe to next one, swipe back to previous image.


Actual results:

First file loaded and played through the .gif but after swiping back image does not play again.


Expected results:

the image should attempt to start playing again.
(Reporter)

Updated

5 years ago
Hardware: Other → ARM
Using: LG Nexus 4 (Android 4.2.2) 
Firefox 27 Nightly, 26 Aurora, 25 Beta 1 and 24 Rc: When you tap on a file and swipe to the next one, it doesn't play. So it happens if you swipe back.
Chrome and Dolphin Browser: When you tap on a file and swipe to the next one and back, the next and previous gifs are played correctly.
This is reproducible on desktop using the mobile user-agent and is Gecko I believe.

When we swipe back we only show the first frame of the GIF.

I inspected the code to see if we get back a different cached result but the image element is the same

<img class="loaded" id="Z8VIcBH" data-id="Z8VIcBH" data-thumb="" data-ext=".jpg" src="http://i.imgur.com/Z8VIcBH.jpg" alt="Flintstones bike">

I also thought this may be a problem since they are defining data-ext and serving us a JPG disguised as an animated GIF, but Gecko can animate those fine when viewing the source standalone.

I have no idea which component this might be an issue in so I am guessing here.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Component: General → ImageLib
Product: Firefox for Android → Core
Version: Firefox 27 → 27 Branch
To reproduce

Use a mobile user agent (Mozilla/5.0 (Android; Mobile; rv:27.0) Gecko/27.0 Firefox/27.0) or via Firefox for Android visit http://m.imgur.com/r/gif, tap the first image, and swipe to next and previous and see the first frame but the image not animated. 

Is this a dupe of an existing Gecko bug?
Keywords: reproducible
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

4 years ago
Appears to be working now
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Issue is resolved - clearing old keywords - qa-wanted clean-up
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.