Closed Bug 919482 Opened 7 years ago Closed 7 years ago

Intermittent layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5 | 163504-1b.html | image comparison (==), max difference: 2,

Categories

(Core :: Layout, defect, P5)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed
firefox-esr24 --- fixed
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: cbook, Assigned: RyanVM)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Windows XP 32-bit mozilla-inbound debug test reftest on 2013-09-23 03:46:13 PDT for push e3a20a3080de

https://tbpl.mozilla.org/php/getParsedLog.php?id=28223152&tree=Mozilla-Inbound

slave: t-xp32-ix-118

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5
Summary: Intermittent TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5 → Intermittent TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5 | 163504-1b.html | image comparison (==), max difference: 2,
I think this has probably the same basic cause as bug 909305. See bug 909305 comment 21 for further explanation.
Why did this regress?  (This test has been running fine since it was added in February 2007.)
Though maybe continuing the discussion in bug 909305 is more useful.
Summary: Intermittent TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5 | 163504-1b.html | image comparison (==), max difference: 2, → Intermittent layout/reftests/bugs/163504-1a.html | image comparison (==), max difference: 2, number of differing pixels: 5 | 163504-1b.html | image comparison (==), max difference: 2,
Priority: -- → P5
Duplicate of this bug: 958767
Tests marked as random-if for too many intermittent failures (see also bug 909305).
Whiteboard: [test marked as random-if] [leave open]
(In reply to TBPL Robot from comment #300)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=33584211&tree=Mozilla-
> Inbound
> Windows 7 32-bit mozilla-inbound debug test reftest on 2014-01-25 09:49:29
> revision: 6638c6ade38c
> slave: t-w732-ix-018
> 
> REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-
> 1a.html | image comparison (==), max difference: 252, number of differing
> pixels: 10
> REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/163504-
> 1b.html | image comparison (==), max difference: 252, number of differing
> pixels: 10

This must be a different failure. The original did not happen on Win7 afaik, its a different number of pixels, and looking at the pixels some of them are very different (like a shade of red vs a shade of black). The original failure mode was off by one or two.
Same fix as 909305.
https://tbpl.mozilla.org/?tree=Try&rev=92f8b0516db0
Assignee: nobody → ryanvm
Attachment #8395842 - Flags: review?(tnikkel)
Comment on attachment 8395842 [details] [diff] [review]
switch to the blue banner image

Sorry for the delay.
Attachment #8395842 - Flags: review?(tnikkel) → review+
Thanks!
https://hg.mozilla.org/integration/mozilla-inbound/rev/53cf2ee44e3d
Whiteboard: [test marked as random-if] [leave open]
https://hg.mozilla.org/mozilla-central/rev/53cf2ee44e3d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31