[RFE] Password manager should offer to not save misspelled logins

VERIFIED WONTFIX

Status

SeaMonkey
Passwords & Permissions
--
enhancement
VERIFIED WONTFIX
17 years ago
4 years ago

People

(Reporter: Robin Green, Assigned: Stephen P. Morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I had a bunch of misspelled logins saved for a site where I couldn't remember
the exact "organisational username" for my organisation. Every time I went back
to the site I was asked to choose between them (though not all of them,
curiously), and of course I couldn't remember which one was the right one. Not
too hard to find them and delete them, once I realised there was an option to do
so in preferences dialog, but it would be nice to have this small feature:

If a server rejects a login (this is unambigious when it's a HTTP AUTH login,
not so easy to determine with web-based logins), a dialog would appear saying
something like "Server seems to have rejected your login (username: xxxxx). If
you misspelled this username, you can choose Don't Remember and Password Manager
will not remember this username." with buttons: "[Don't Remember] [Remember Anyway]"
The choice should be presented just in case the login failure is due to a server
bug rather than user error.

Misspelled passwords don't matter nearly so much because they will be
overwritten when the correct password is entered.
(Assignee)

Comment 1

17 years ago
You don't need to go to preference dialog to do the deleting.  It's more 
obviously found in the password manager dialog itself.

I'm pretty sure that this rejection is already being done for http and ftp 
authentication.  If it isn't, then there's a bug in the http/ftp code and a bug 
about that should be filed against the networking group.

Regarding your comment about it being not so easy to determine with a web-based 
login, I would say that's an understatement.  There really is no practical test 
that I can make to determine that a web-based login failed.  That's the reason 
such rejection had not been built in to the password manager already.  Therefore 
I have to mark this bug as wont-fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
Agreed, marking verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Depends on: 958803
No longer depends on: 958803
You need to log in before you can comment on or make changes to this bug.