Closed Bug 919601 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen] Install and launch Facebook or Twitter apps from Homescreen Search not appearing on Homescreen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox27 affected, b2g-v1.2 unaffected)

RESOLVED FIXED
Tracking Status
firefox27 --- affected
b2g-v1.2 --- unaffected

People

(Reporter: mclemmons, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Description: Attempts to install Facebook and Twitter apps from Homescreen Search not appearing on Homescreen 


Repro Steps:
1) Updated Buri to Build ID: 20130923040214 Master/m-c
2) Navigate to the Search box on the Home Screen
3) Tap on the search bar to reveal the categories
4) Select the Social Category button
5) Select the Facebook or Twitter button
6) Login to Facebook or Twitter Account
7) Swipe at the bottom of the screen and select the star button
8) Tap the Facebook or Twitter gray button 
9) Tap Add to Home Screen button
10) Tap Home button


Actual:
Facebook or Twitter app not present on homescreen

Expected:
Facebook or Twitter app present on homescreen

Environmental Variables
Build ID: 20130923040214
Gecko: http://hg.mozilla.org/mozilla-central/rev/f97307cb4c95
Gaia: 3408cc3f6b190c8cd31832fbb8cd2ae571041f29
Platform Version: 27.0a1
Base image: 20130923
Repro frequency: (100%, 10/10)
Test Suite Name: (Homescreen)

Link to failed test case: https://moztrap.mozilla.org/manage/case/5856/
See attached: (logcat)
Additional notes: Attempted on two different Buri devices on the same build for Master/m-c
blocking-b2g: --- → koi?
Component: Gaia::Homescreen → Gaia::Everything.me
In this point we haven't the main homescreen window so I think that is a regression on system app

https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/bookmark_editor.js#L56
Component: Gaia::Everything.me → Gaia::System
Does this reproduce on 1.2? I'm assuming it does, but double check this.
This does not reproduce on 1.2.

Environmental Variables
Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
blocking-b2g: koi? → 1.3?
Zac filed Bug 919584 for the same issue on Browser.

From what I can see using today's build this happens across the board with all e.me app using today's build.
QA Contact: sparsons
This issue started on the Buri 1.3 Build ID: 20130923040214

Environmental Variables
Build ID: 20130923040214
Gecko: http://hg.mozilla.org/mozilla-central/rev/f97307cb4c95
Gaia: 3408cc3f6b190c8cd31832fbb8cd2ae571041f29
Platform Version: 27.0a1

Last working build Buri 1.3 Build ID: 20130922040204

Environmental Variables
Build ID: 20130922040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/8b4d14afc4f6
Gaia: 37866768b8abda56d089c8fe96ec5298fc1df696
Platform Version: 27.0a1
RIL Version: 01.01.00.019.197
Whiteboard: [Dupe of bug 919584?]
Should be fixed for the same reasons as bug 919584.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Dupe of bug 919584?]
You need to log in before you can comment on or make changes to this bug.