Closed Bug 919656 Opened 6 years ago Closed 6 years ago

Australis tab curves on Windows XP and 7 are missing their backgrounds.

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: mconley, Assigned: bas.schouten)

References

Details

(Keywords: regression, Whiteboard: [Australis:M9][Australis:P1][fixed-in-ux])

Attachments

(2 files)

See attached screenshot.

According to mozregression:

Last good nightly: 2013-09-21
First bad nightly: 2013-09-22

Pushlog:
http://hg.mozilla.org/projects/ux/pushloghtml?fromchange=95055789d6aa&tochange=d90769086ea2

Wtf - that's a merge changeset. :(
I believe this was caused by the Azure merge.

Setting gfx.content.azure.enabled to false fixes the issue.
Blocks: 907926
Assignee: nobody → matt.woodrow
See also bug 919471, I bet its the same cause.
Component: Theme → Graphics
Product: Firefox → Core
This is affecting Windows 7 as well.
OS: Windows XP → Windows 7
Summary: Australis tab curves on Windows XP are missing their backgrounds. → Australis tab curves on Windows XP and 7 are missing their backgrounds.
Attachment #808703 - Attachment description: Wacky tabs → Missing backgrounds on Windows XP
I agree with :nrc, this is likely related to bug 919471. Enabling HWA makes the problem go away on my Windows 7 machine.
Reassigning this to Bas.

This looks like a bug with complex svg clip-paths and the cairo azure backend. Bas is looking into exactly that right now, and his work will hopefully fix this :)
Assignee: matt.woodrow → bas
I strongly suspect Matt is right, as this also fixed bug 919471.
Depends on: 918613
Duplicate of this bug: 921868
This appears to have been fixed via bug 918613, which was merged into the UX branch in this merge changeset:

https://hg.mozilla.org/projects/ux/rev/e62689b72cc6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M?][Australis:P1] → [Australis:M9][Australis:P1][fixed-in-ux]
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.