Closed Bug 91967 Opened 19 years ago Closed 19 years ago

Context menu edit action is not set up correctly

Categories

(Core :: DOM: Editor, defect)

x86
Windows 98
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 88123

People

(Reporter: morgan_toal, Assigned: Brade)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

When right clicking on an html file in Windows Explorer and choosing edit, I get
the editor to open with the "Ender HTML Test Page". I checked the actions for
file type html, for the edit action it had: "C:\PROGRAM FILES\MICROSOFT
OFFICE\OFFICE\msohtmed.exe". I changed it to C:\PROGRA~1\MOZILL~1.2\MOZILLA.EXE
-edit "%1", which is what I think it should be, and this still causes the Ender
HTML page to come up.

Reproducible: Always
Steps to Reproduce:
1.Right click on an html file
2.Do edit
3.Watch the Ender Test Page come up instead of your document.

Actual Results:  The wrong file was opened in editor.

Expected Results:  Should have edited the file you right clicked on
OK, now that I exited and restarted Mozilla, the modifications to the context
menu I made have the desired effect, i.e. it no longer gives me the Ender HTML
Test Page, it gvies me what I right clicked and did edit on.

So, what would need to happen is whoever writes the installer I guess should
include the correct action for "edit" for the html file type in Windows Explorer.

mtoal
Summary: Context menu actions are not set up correctly → Context menu edit action is not set up correctly
Over to installer.
Assignee: beppe → ssu
Status: UNCONFIRMED → NEW
Component: Editor → Installer
Ever confirmed: true
QA Contact: sujay → gemal
Sean: is this installer? or should it be the browser that does the reg.edit add. 
You could also imaging other reg.db adds.
The installer does not set the browser as the default handler for http or html.  
The browser does that at startup.
as Sean said: "The installer does not set the browser as the default handler for 
http or html. The browser does that at startup."
Assignee: ssu → asa
Component: Installer → Browser-General
QA Contact: gemal → doronr
-->editor
Assignee: asa → brade
Component: Browser-General → Editor
QA Contact: doronr → sujay


*** This bug has been marked as a duplicate of 88123 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.