Closed Bug 919784 Opened 6 years ago Closed 6 years ago

Frequent mochitest-gl crash / timeout on x86 emulator

Categories

(Firefox for Android :: General, defect)

x86
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 927602

People

(Reporter: gbrown, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #907383 +++

x86 runs of mochitest-gl frequently (always?) fail on Cedar:

https://tbpl.mozilla.org/php/getParsedLog.php?id=28198658&tree=Cedar&full=1#error0

06:46:50     INFO - 3343 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl instanceof WebGLRenderingContext is true
06:46:50     INFO - 3344 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_Traceback (most recent call last):
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/runtests.py", line 605, in runTests
06:46:50     INFO -     onLaunch=onLaunch)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/automation.py", line 879, in runApp
06:46:50     INFO -     status = self.waitForFinish(proc, utilityPath, timeout, maxTime, startTime, debuggerInfo, symbolsPath)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/remoteautomation.py", line 74, in waitForFinish
06:46:50     INFO -     status = proc.wait(timeout = maxTime)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/remoteautomation.py", line 297, in wait
06:46:50     INFO -     while (self.dm.getTopActivity() == self.procName):
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/droid.py", line 154, in getTopActivity
06:46:50     INFO -     return self._runCmds([{ 'cmd': "activity" }]).strip()
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 152, in _runCmds
06:46:50     INFO -     self._sendCmds(cmdlist, outputfile, timeout, retryLimit=retryLimit)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 134, in _sendCmds
06:46:50     INFO -     raise err
06:46:50     INFO - DMError: Automation Error: Timeout in command activity
06:46:50     INFO - Mochitest ERROR | Automation Error: Received unexpected exception while running application
06:46:50     INFO - 
06:46:50     INFO - test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createBuffer() instanceof WebGLBuffer is true
06:46:50     INFO - 3345 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createFramebuffer() instanceof WebGLFramebuffer is true
06:46:50     INFO - 3346 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createProgram() instanceof WebGLProgram is true
06:46:50     INFO - 3347 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createRenderbuffer() instanceof WebGLRenderbuffer is true
06:46:50     INFO - 3348 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createShader(gl.VERTEX_SHADER) instanceof WebGLShader is true
06:46:50     INFO - 3349 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.createTexture() instanceof WebGLTexture is true
06:46:50     INFO - 3350 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.getUniformLocation(program, "color") instanceof WebGLUniformLocation is true
06:46:50     INFO - 3351 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.getActiveAttrib(program, 0) instanceof WebGLActiveInfo is true
06:46:50     INFO - 3352 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - gl.getActiveUniform(program, 0) instanceof WebGLActiveInfo is true
06:46:50     INFO - 3353 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLRenderingContext threw an error
06:46:50     INFO - 3354 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLActiveInfo threw an error
06:46:50     INFO - 3355 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLBuffer threw an error
06:46:50     INFO - 3356 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLFramebuffer threw an error
06:46:50     INFO - 3357 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLProgram threw an error
06:46:50     INFO - 3358 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLRenderbuffer threw an error
06:46:50     INFO - 3359 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLShader threw an error
06:46:50     INFO - 3360 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLTexture threw an error
06:46:50     INFO - 3361 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLUniformLocation threw an error
06:46:50     INFO - 3362 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] Test passed - new WebGLShaderPrecisionFormat threw an error
06:46:50     INFO - 3363 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/instanceof-test.html] All 20 test(s) passed
06:46:50     INFO - 3364 INFO TEST-INFO | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/misc/invalid-passed-params.html] (WebGL mochitest) Starting test page
06:46:50     INFO - WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
06:46:50     INFO - Mochitest INFO  | runtests.py | Running tests: end.
06:46:50     INFO - Mochi-Remote ERROR | Automation Error: Exception caught while running tests
06:46:50     INFO - Traceback (most recent call last):
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/runtestsremote.py", line 692, in main
06:46:50     INFO -     retVal = mochitest.runTests(options)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/runtests.py", line 624, in runTests
06:46:50     INFO -     self.cleanup(manifest, options)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/runtestsremote.py", line 240, in cleanup
06:46:50     INFO -     if self._dm.fileExists(self.remoteLog):
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 404, in fileExists
06:46:50     INFO -     return filename in self.listFiles(containingpath)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 408, in listFiles
06:46:50     INFO -     if not self.dirExists(rootdir):
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 389, in dirExists
06:46:50     INFO -     ret = self._runCmds([{ 'cmd': 'isdir ' + remotePath }]).strip()
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 152, in _runCmds
06:46:50     INFO -     self._sendCmds(cmdlist, outputfile, timeout, retryLimit=retryLimit)
06:46:50     INFO -   File "/builds/slave/talos-slave/test/build/tests/mochitest/devicemanagerSUT.py", line 134, in _sendCmds
06:46:50     INFO -     raise err
06:46:50     INFO - DMError: Automation Error: Timeout in command isdir /mnt/sdcard/tests/logs
If I run mochitest-gl manually on the loaner, it sometimes (often?) succeeds. Sometimes Fennec crashes, but the stack is useless -- bug 916923.

7729 INFO TEST-END | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | finished in 636142ms
7730 INFO TEST-START | Shutdown
7731 INFO Passed:  7026
7732 INFO Failed:  0
7733 INFO Todo:    308
7734 INFO Slowest: 4004ms - /tests/content/canvas/test/webgl/non-conf-tests/test_webgl_conformance.html
7735 INFO SimpleTest FINISHED
INFO | automation.py | Application ran for: 0:11:45.823029

My manual command:

/home/cltbld/tests/scripts/scripts/build/venv/bin/python /home/cltbld/tests/scripts/scripts/build/tests/mochitest/runtestsremote.py --autorun --close-when-done --dm_trans=sut --console-level INFO --app org.mozilla.fennec --remote-webserver 10.0.2.2 --xre-path /home/cltbld/tests/scripts/scripts/build/hostutils/xre --utility-path /home/cltbld/tests/scripts/scripts/build/hostutils/bin --certificate-path /home/cltbld/tests/scripts/scripts/build/tests/certs --deviceIP 127.0.0.1 --devicePort 20701 --http-port 8888 --ssl-port 4445 --symbols-path crashreporter-symbols.zip --test-path content/canvas/test/webgl

Cedar:

/builds/slave/talos-slave/test/build/venv/bin/python /builds/slave/talos-slave/test/build/tests/mochitest/runtestsremote.py --autorun --close-when-done --dm_trans=sut --console-level=INFO --app=org.mozilla.fennec --remote-webserver=10.0.2.2 --xre-path=/builds/slave/talos-slave/test/build/hostutils/xre --utility-path=/builds/slave/talos-slave/test/build/hostutils/bin --deviceIP=127.0.0.1 --devicePort=20703 --http-port=8856 --ssl-port=4456 --certificate-path=/builds/slave/talos-slave/test/build/tests/certs --symbols-path=http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/cedar-android-x86/1379761321/fennec-27.0a1.en-US.android-i386.crashreporter-symbols.zip --test-path content/canvas/test/webgl
Blocks: 936226
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927602
You need to log in before you can comment on or make changes to this bug.